数据库目录

表
序号 | 表名 | 表说明
0 | cap.Published |
0 | cap.Received |
0 | dbo.AB_HeightStand | 新的身高标准
0 | dbo.AB_Prescription | 安邦儿童处方
0 | dbo.AB_PrescriptionByAge | 邦儿童处方,按年龄
0 | dbo.AB_WeightStand | 安邦体重标准
0 | dbo.T_Family | 家庭成员
0 | dbo.T_FamilyData | 家庭成员数据
0 | dbo.T_RegUser | 注册用户
0 | dbo.T_Result | 历史记录
0 | dbo.T_UserData | 用户数据
0 | dbo.T_UserWX | 客户绑定信息
0 | dbo.YB_Account | 账户系统
0 | dbo.YB_Advice | 意见反馈
0 | dbo.YB_AuditLogger | 审计日志
0 | dbo.YB_Banner | 轮播图
0 | dbo.YB_BannerContent | 轮播图内容
0 | dbo.YB_BannerEqu | 轮播图绑定的设备
0 | dbo.YB_BmiStand | BMI标准
0 | dbo.YB_BodyMeasure | 八电极测量结果
0 | dbo.YB_BodyResult | 八电极测量记录
0 | dbo.YB_Business | 客户列表
0 | dbo.YB_BusinessOffice | 客户名下的公众号 小程序
0 | dbo.YB_BusinessRealData | 客户统计数据
0 | dbo.YB_BusinessReportData | 商户日统计
0 | dbo.YB_BusinessWX | 客户微信绑定信息
0 | dbo.YB_ChildBodyDetail |
0 | dbo.YB_ChildBodyQA |
0 | dbo.YB_ChildPhysique | 儿童体质
0 | dbo.YB_ChildPhysiqueResult | 儿童体质结果
0 | dbo.YB_ChildPhysiqueResultDetail | 儿童体质结果详情
0 | dbo.YB_ChildPrescriptionByAge | 儿童处方,按年龄
0 | dbo.YB_ChildrenPrescription | 儿童处方
0 | dbo.YB_Combined | 平台数据汇总表
0 | dbo.YB_DayReport | 每日数据统计
0 | dbo.YB_Device | 设备表
0 | dbo.YB_DeviceAlloc | 设备分配记录
0 | dbo.YB_DeviceDayReportData | 设备日统计数据
0 | dbo.YB_DeviceType | 设备类型
0 | dbo.YB_DeviceTypeApp | 小程序绑定的设备类型
0 | dbo.YB_DeviceTypeExt | 设备类型对照表
0 | dbo.YB_EquRealData | 设备合计数据
0 | dbo.YB_ErrorLogger | 错误日志
0 | dbo.YB_ExPress | 物流信息
0 | dbo.YB_Family | 家庭成员
0 | dbo.YB_FamilyData | 家庭成员数据,针对全设备类型
0 | dbo.YB_FamilyRealData | 家庭成员实时数据
0 | dbo.YB_FamilyReportData | 家庭成员统计数据,按月统计,去每月的最高体重和身高
0 | dbo.YB_FamilyTarget | 家庭成员目标体重
0 | dbo.YB_HeadStand | 头围标准
0 | dbo.YB_HeightStand | 身高标准
0 | dbo.YB_LXBodyAns | 丽秀体质提交的问卷
0 | dbo.YB_LXBodyGuide | 丽秀中医指导
0 | dbo.YB_LXBodyQA | 丽秀体质问题
0 | dbo.YB_LXBodyResult | 丽秀体质提交的问卷结果
0 | dbo.YB_LXBodyType | 丽秀体质类型
0 | dbo.YB_Measure | 测量记录计算结果
0 | dbo.YB_Menu | 菜单表
0 | dbo.YB_MiniProgramHistory | 小程序提交审核记录
0 | dbo.YB_MiniPrograms | 小程序列表
0 | dbo.YB_MiniProgramsDraft | 小程序草稿
0 | dbo.YB_MiniProgramsTpl | 小程序模版
0 | dbo.YB_MiniProgramSubscribeMessageTpl | 小程序订阅消息模板列表
0 | dbo.YB_nBodyMeasure | 八电极标准数据
0 | dbo.YB_NewHeightStand | 新的身高标准
0 | dbo.YB_NewWeightStand | 新的体重标准
0 | dbo.YB_nMeasureResult | 用户计算结果
0 | dbo.YB_nMenu | 菜单表
0 | dbo.YB_nMenuAction | 菜单按钮
0 | dbo.YB_NoticeLog | 通知日志
0 | dbo.YB_NoticeLogger | 通知日志
0 | dbo.YB_nResult | 测量记录
0 | dbo.YB_nResultAdd | 手动添加的记录
0 | dbo.YB_nRole | 角色表
0 | dbo.YB_nRoleAction | 角色按钮
0 | dbo.YB_nRoleMenu | 角色菜单表
0 | dbo.YB_nSecInfo | 科普资讯
0 | dbo.YB_nSecInfoAppId | 科普资讯appid
0 | dbo.YB_nSecInfoContent | 科普资讯内容
0 | dbo.YB_nUserResult | 测量记录扩展
0 | dbo.YB_OfficlaAccount | 微信公众号 小程序
0 | dbo.YB_OpenWXConfig | 微信开放平台配置
0 | dbo.YB_Order | 设备订单,适用于扫码关注流程
0 | dbo.YB_OrderEqu | 订单绑定的设备
0 | dbo.YB_OutProduct | 出货系统
0 | dbo.YB_OutProductDev | 出货订单对应的设备
0 | dbo.YB_PrintCode | 打印编码
0 | dbo.YB_PrintCodeEqu | 打印编码对应的设备
0 | dbo.YB_RegUser | 注册用户表
0 | dbo.YB_Result | 测量记录
0 | dbo.YB_ResultAdd | 手动添加的记录
0 | dbo.YB_ResultExt | 测量记录扩展表
0 | dbo.YB_Role | 角色表
0 | dbo.YB_RoleMenu | 角色菜单表
0 | dbo.YB_ScanResult | 扫码关注公众号记录
0 | dbo.YB_SecInfo | 科普资讯
0 | dbo.YB_SecInfoContent | 科普资讯内容
0 | dbo.YB_SecInfoType | 科普资讯类型
0 | dbo.YB_TestEnm | 测试
0 | dbo.YB_UserChildBody |
0 | dbo.YB_UserDev | 用户使用过的设备列表
0 | dbo.YB_UserEqu | 用户使用过的设备类型
0 | dbo.YB_UserLastData | 用户最近的测量信息
0 | dbo.YB_UserRealData | 用户实时数据
0 | dbo.YB_UserSubscribeMessage | 用户订阅消息
0 | dbo.YB_UserWX | 注册用户管理的微信数据
0 | dbo.YB_WeightStand | 体重标准
0 | dbo.YB_WifiBind | wifi绑定记录
0 | dbo.YB_WXCustomService | 微信客服
0 | dbo.YB_WXFans | 粉丝数据表
0 | dbo.YB_WXFansExt | 用户关注公众号相关
0 | dbo.YB_WXMessage | 微信公众号关键字
0 | dbo.YB_WXRun | 微信步数
存储过程
序号 | 存储过程名称
1 | proc_body_binduser
2 | proc_ClearDayData
3 | proc_fanssubcribestatus
4 | proc_getmeasureitem_page
5 | PROC_GetOrder
6 | PROC_GetScanOrder
7 | proc_insertresult
8 | proc_insertscanresult
9 | proc_reportDayData
10 | proc_reportmonthData
11 | proc_saveresult
12 | proc_updateresult
13 | report_childheightandweight


cap.Published

cap.Published 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | bigint |  |  | √ |  |  |  |
2 | Version | nvarchar | 20 |  |  |  |  |  |
3 | Name | nvarchar | 200 |  |  |  |  |  |
4 | Content | nvarchar | -1 |  |  |  | √ |  |
5 | Retries | int |  |  |  |  |  |  |
6 | Added | datetime2 |  |  |  |  |  |  |
7 | ExpiresAt | datetime2 |  |  |  |  | √ |  |
8 | StatusName | nvarchar | 50 |  |  |  |  |  |


cap.Received

cap.Received 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | bigint |  |  | √ |  |  |  |
2 | Version | nvarchar | 20 |  |  |  |  |  |
3 | Name | nvarchar | 200 |  |  |  |  |  |
4 | Group | nvarchar | 200 |  |  |  | √ |  |
5 | Content | nvarchar | -1 |  |  |  | √ |  |
6 | Retries | int |  |  |  |  |  |  |
7 | Added | datetime2 |  |  |  |  |  |  |
8 | ExpiresAt | datetime2 |  |  |  |  | √ |  |
9 | StatusName | nvarchar | 50 |  |  |  |  |  |


dbo.AB_HeightStand

dbo.AB_HeightStand 新的身高标准 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Month | decimal | 6 | 2 |  |  |  |  | 月龄
3 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女
4 | f3sd | decimal | 4 | 1 |  |  |  |  | -3SD
5 | f2sd | decimal | 4 | 1 |  |  |  |  | 2SD
6 | f1sd | decimal | 4 | 1 |  |  |  |  | 1SD
7 | median | decimal | 4 | 1 |  |  |  |  | 中位数
8 | z1sd | decimal | 4 | 1 |  |  |  |  | 1SD
9 | z2sd | decimal | 4 | 1 |  |  |  |  | 2SD
10 | z3sd | decimal | 4 | 1 |  |  |  |  | 3SD


dbo.AB_Prescription

dbo.AB_Prescription 安邦儿童处方 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Type | int |  |  |  |  |  |  | 类型,1-身高标准,2-BMI标准,3-身高标准
3 | Level | int |  |  |  |  |  |  | 标准,参考处方文档
4 | Nutrition | text | 2147483647 |  |  |  |  |  | 营养,全年龄
5 | Sport | text | 2147483647 |  |  |  |  |  | 运动,全年龄
6 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.AB_PrescriptionByAge

dbo.AB_PrescriptionByAge 邦儿童处方,按年龄 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  | 主键
2 | MinAge | int |  |  |  |  |  |  | 最小年龄,月龄,如果是-1则表示全年龄
3 | MaxAge | int |  |  |  |  |  |  | 最大年龄,月龄,如果是-1则表示全年龄
4 | Type | int |  |  |  |  |  |  | 类型,1-运动,2-睡眠,3-情绪
5 | Content | text | 2147483647 |  |  |  |  |  | 内容


dbo.AB_WeightStand

dbo.AB_WeightStand 安邦体重标准 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Month | decimal | 6 | 2 |  |  |  |  | 月龄
3 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女
4 | f3sd | decimal | 4 | 1 |  |  |  |  | -3SD
5 | f2sd | decimal | 4 | 1 |  |  |  |  | 2SD
6 | f1sd | decimal | 4 | 1 |  |  |  |  | 1SD
7 | median | decimal | 4 | 1 |  |  |  |  | 中位数
8 | z1sd | decimal | 4 | 1 |  |  |  |  | 1SD
9 | z2sd | decimal | 4 | 1 |  |  |  |  | 2SD
10 | z3sd | decimal | 4 | 1 |  |  |  |  | 3SD


dbo.T_Family

dbo.T_Family 家庭成员 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Name | nvarchar | 100 |  |  |  |  |  | 昵称
3 | HeadImg | varchar | 200 |  |  |  |  |  | 头像
4 | UserId | uniqueidentifier | 36 |  |  |  |  |  | 用户ID
5 | CreateTime | datetime |  |  |  |  |  |  | 注册时间


dbo.T_FamilyData

dbo.T_FamilyData 家庭成员数据 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Height | decimal | 18 | 2 |  |  |  |  | 身高值,CM
3 | Weight | decimal | 18 | 2 |  |  |  |  | 体重,CM
4 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女
5 | Brithday | datetime |  |  |  |  | √ |  | 出生年月
6 | LastResultId | uniqueidentifier | 36 |  |  |  | √ |  | 最近记录ID
7 | LastResultTime | datetime |  |  |  |  | √ |  | 最近记录时间


dbo.T_RegUser

dbo.T_RegUser 注册用户 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Name | nvarchar | 100 |  |  |  |  |  | 昵称
3 | HeadImg | varchar | 200 |  |  |  |  |  | 头像
4 | CreateTime | datetime |  |  |  |  |  |  | 注册时间


dbo.T_Result

dbo.T_Result 历史记录 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Height | decimal | 18 | 2 |  |  |  |  | 身高值,CM
3 | Weight | decimal | 18 | 2 |  |  |  |  | 体重,CM
4 | BMI | decimal | 18 | 2 |  |  |  |  | BMI值
5 | UserId | uniqueidentifier | 36 |  |  |  |  |  | 用户ID
6 | ResultTime | datetime |  |  |  |  |  |  | 测量时间
7 | CreateTime | datetime |  |  |  |  |  |  | 记录时间
8 | FamilyId | uniqueidentifier | 36 |  |  |  |  |  | 家庭成员ID


dbo.T_UserData

dbo.T_UserData 用户数据 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Height | decimal | 18 | 2 |  |  |  |  | 身高值,CM
3 | Weight | decimal | 18 | 2 |  |  |  |  | 体重,CM
4 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女
5 | Brithday | datetime |  |  |  |  | √ |  | 出生年月
6 | LastResultTime | datetime |  |  |  |  | √ |  | 最近记录时间


dbo.T_UserWX

dbo.T_UserWX 客户绑定信息 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | UserId | uniqueidentifier | 36 |  |  |  |  |  | 用户ID
3 | OpenId | varchar | 50 |  |  |  |  |  | 小程序/字节openid


dbo.YB_Account

dbo.YB_Account 账户系统 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Phone | varchar | 20 |  |  |  |  |  | 手机号
3 | UserName | varchar | 50 |  |  |  |  |  | 登录账户名
4 | RealName | nvarchar | 50 |  |  |  |  |  | 显示的名称
5 | Password | varchar | 50 |  |  |  |  |  | 密码,MD5加密
6 | Secret | varchar | 50 |  |  |  |  |  | 密码密钥
7 | RoleId | int |  |  |  |  |  |  | 所属的角色ID
8 | AccountType | int |  |  |  |  |  |  | 账户类型,1-普通,2-平台
9 | BusinessId | int |  |  |  |  |  |  | 关联的客户ID
10 | Status | int |  |  |  |  |  |  | 状态,0-禁用,1-启用
11 | LastVisitIP | varchar | 50 |  |  |  |  |  | 最近访问的IP地址
12 | LastVisitTime | datetime |  |  |  |  |  |  | 最近访问时间
13 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
14 | HeadImg | varchar | 100 |  |  |  | √ |  | 头像
15 | nRoleId | uniqueidentifier | 36 |  |  |  | √ |  | 所属的角色ID


dbo.YB_Advice

dbo.YB_Advice 意见反馈 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Phone | varchar | 50 |  |  |  |  |  | 手机号
3 | Content | nvarchar | 500 |  |  |  |  |  |
4 | CreateTime | datetime |  |  |  |  |  |  |


dbo.YB_AuditLogger

dbo.YB_AuditLogger 审计日志 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Title | nvarchar | 100 |  |  |  |  |  | 操作内容
3 | TableName | nvarchar | 100 |  |  |  |  |  | 表名
4 | ColumnName | nvarchar | 100 |  |  |  |  |  | 操作内容
5 | OldValue | nvarchar | -1 |  |  |  |  |  | 旧值
6 | NewValue | nvarchar | -1 |  |  |  |  |  | 新值
7 | CreatTime | datetime |  |  |  |  |  |  | 操作时间
8 | BusinessId | int |  |  |  |  |  |  | 操作人Id
9 | UserName | varchar | 255 |  |  |  |  |  | 操作人名称
10 | Operate | int |  |  |  |  |  |  | 操作方式：新增、更新、删除


dbo.YB_Banner

dbo.YB_Banner 轮播图 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | PositionType | int |  |  |  |  |  |  | 广告类型,1-开屏广告,2-轮播图广告
3 | HeadImg | varchar | 100 |  |  |  |  |  | 封面图
4 | Name | nvarchar | 100 |  |  |  |  |  | 轮播图名称
5 | Type | int |  |  |  |  |  |  | 类型,1-文本,2-链接,3-跳转小程序
6 | StartTime | datetime |  |  |  |  |  |  | 生效时间
7 | EndTime | datetime |  |  |  |  |  |  | 结束时间
8 | Status | int |  |  |  |  |  |  | 状态,0-未开启,1-正常运行,2-已关闭
9 | StatusRemark | nvarchar | 100 |  |  |  |  |  | 状态备注
10 | ClickCount | int |  |  |  |  |  |  | 点击数量
11 | BusinessId | int |  |  |  |  |  |  | 客户ID
12 | Createtime | datetime |  |  |  |  |  |  | 创建时间
13 | Appid | varchar | 50 |  |  |  | √ |  | 小程序appid


dbo.YB_BannerContent

dbo.YB_BannerContent 轮播图内容 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | BannerId | int |  |  |  |  |  |  | 轮播图ID
2 | Content | text | 2147483647 |  |  |  |  |  | 内容


dbo.YB_BannerEqu

dbo.YB_BannerEqu 轮播图绑定的设备 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | BannerId | int |  |  |  |  |  |  | 轮播图ID
2 | EquId | int |  |  |  |  |  |  | 设备ID


dbo.YB_BmiStand

dbo.YB_BmiStand BMI标准 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Month | decimal | 6 | 2 |  |  |  |  | 月龄
3 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女
4 | f1sd | decimal | 4 | 1 |  |  |  |  | 1SD
5 | median | decimal | 4 | 1 |  |  |  |  | 中位数
6 | z1sd | decimal | 4 | 1 |  |  |  |  | 1SD
7 | z2sd | decimal | 4 | 1 |  |  |  |  | 2SD


dbo.YB_BodyMeasure

dbo.YB_BodyMeasure 八电极测量结果 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | ResultId | int |  |  |  |  |  |  | 测量记录ID
3 | BodyMuscle | decimal | 18 | 2 |  |  |  |  | 躯干肌肉率
4 | LeftFootMuscle | decimal | 18 | 2 |  |  |  |  | 左脚肌肉率
5 | RightFootMuscle | decimal | 18 | 2 |  |  |  |  | 右脚肌肉率
6 | LeftHandMuscle | decimal | 18 | 2 |  |  |  |  | 左手肌肉率
7 | RightHandMuscle | decimal | 18 | 2 |  |  |  |  | 右手肌肉率
8 | BodyFat | decimal | 18 | 2 |  |  |  |  | 躯干脂肪率
9 | LeftFootFat | decimal | 18 | 2 |  |  |  |  | 左脚脂肪率
10 | RightFootFat | decimal | 18 | 2 |  |  |  |  | 右脚脂肪率
11 | LeftHandFat | decimal | 18 | 2 |  |  |  |  | 左手脂肪率
12 | RightHandFat | decimal | 18 | 2 |  |  |  |  | 右手脂肪率
13 | BodyMuscleVal | decimal | 18 | 2 |  |  |  |  | 躯干肌肉量
14 | LeftFootMuscleVal | decimal | 18 | 2 |  |  |  |  | 左脚肌肉量
15 | RightFootMuscleVal | decimal | 18 | 2 |  |  |  |  | 右脚肌肉量
16 | LeftHandMuscleVal | decimal | 18 | 2 |  |  |  |  | 左手肌肉量
17 | RightHandMuscleVal | decimal | 18 | 2 |  |  |  |  | 右手肌肉量
18 | BodyFatVal | decimal | 18 | 2 |  |  |  |  | 躯干脂肪量
19 | LeftFootFatVal | decimal | 18 | 2 |  |  |  |  | 左脚脂肪量
20 | RightFootFatVal | decimal | 18 | 2 |  |  |  |  | 右脚脂肪量
21 | LeftHandFatVal | decimal | 18 | 2 |  |  |  |  | 左手脂肪量
22 | RightHandFatVal | decimal | 18 | 2 |  |  |  |  | 右手脂肪量
23 | SfrVal | decimal | 18 | 2 |  |  |  |  | 皮下脂肪量,kg
24 | IdealWeight | decimal | 18 | 2 |  |  |  |  | 理想体重
25 | SkeletalMuscle | decimal | 18 | 2 |  |  |  |  | 骨骼肌量,kg
26 | LevelJson | varchar | 500 |  |  |  |  | '‘’' | 等级标准


dbo.YB_BodyResult

dbo.YB_BodyResult 八电极测量记录 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | ResultId | int |  |  |  |  |  |  | 设备机器码
3 | LeftArmImp | decimal | 18 | 2 |  |  |  |  | 左手阻抗
4 | RightArmImp | decimal | 18 | 2 |  |  |  |  | 右手阻抗
5 | LeftLegImp | decimal | 18 | 2 |  |  |  |  | 左脚阻抗
6 | RightLegImp | decimal | 18 | 2 |  |  |  |  | 右脚阻抗
7 | BodyImp | decimal | 18 | 2 |  |  |  |  | 全身阻抗


dbo.YB_Business

dbo.YB_Business 客户列表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Code | varchar | 100 |  |  |  |  |  | 编码
3 | ParentId | int |  |  |  |  |  |  | 上级客户ID
4 | Name | nvarchar | 100 |  |  |  |  |  | 客户名称
5 | Phone | varchar | 20 |  |  |  |  |  | 手机号
6 | Type | int |  |  |  |  |  | 1 | 类型,1-系统默认
7 | Remark | nvarchar | 200 |  |  |  |  |  | 备注
8 | Status | int |  |  |  |  |  |  | 状态,0-禁用,1-启用
9 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_BusinessOffice

dbo.YB_BusinessOffice 客户名下的公众号 小程序 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | BusinessId | int |  |  |  |  |  |  |
3 | AppId | varchar | 50 |  |  |  |  |  | 公众号appid
4 | CreateTime | datetime |  |  |  |  |  |  | 添加时间


dbo.YB_BusinessRealData

dbo.YB_BusinessRealData 客户统计数据 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | BusinessId | int |  |  |  |  |  |  | 客户ID
3 | TodayResultCnt | int |  |  |  |  |  |  | 今日称重次数
4 | TotalResultCnt | int |  |  |  |  |  |  | 累计称重次数
5 | TodayRealCnt | int |  |  |  |  |  |  | 今日关注数量
6 | TotalRealCnt | int |  |  |  |  |  |  | 累计关注数量
7 | TodayIncome | decimal | 18 | 2 |  |  |  |  | 今日收益,单位为分
8 | TotalIncome | decimal | 18 | 2 |  |  |  |  | 累计收益
9 | Balance | decimal | 18 | 2 |  |  |  |  | 可提现余额
10 | TotalTxAmount | decimal | 18 | 2 |  |  |  |  | 累计提现金额
11 | DevCount | int |  |  |  |  |  |  | 设备台数
12 | TodayDevCount | int |  |  |  |  |  | 0 | 今日活跃设备台数
13 | BusinessCount | int |  |  |  |  |  |  | 子商户数量
14 | CreateTime | datetime |  |  |  |  |  |  |


dbo.YB_BusinessReportData

dbo.YB_BusinessReportData 商户日统计 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | DayResultCnt | int |  |  |  |  |  |  | 日测量次数
3 | DayDevCnt | int |  |  |  |  |  |  | 日活跃设备数量
4 | DayInCome | decimal | 18 | 2 |  |  |  |  |
5 | BusinessId | int |  |  |  |  |  |  |
6 | RecordTime | date | 10 | 0 |  |  |  |  | 记录时间


dbo.YB_BusinessWX

dbo.YB_BusinessWX 客户微信绑定信息 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | BusinessId | int |  |  |  |  |  |  | 客户ID
3 | UserId | int |  |  |  |  |  |  | 账户ID
4 | OpenId | varchar | 50 |  |  |  |  |  | 小程序openid
5 | UnionId | varchar | 50 |  |  |  |  |  | unionid
6 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_ChildBodyDetail

dbo.YB_ChildBodyDetail 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Type | int |  |  |  |  |  |  | 体质类型
3 | Define | text | 2147483647 |  |  |  |  |  | 定义
4 | Proper | text | 2147483647 |  |  |  |  |  | 形体特征
5 | Show | text | 2147483647 |  |  |  |  |  | 素体表现
6 | Food | text | 2147483647 |  |  |  |  |  | 饮食
7 | Growth | text | 2147483647 |  |  |  |  |  | 生长发育
8 | OutsideEnv | text | 2147483647 |  |  |  |  |  | 外界环境
9 | Conver | text | 2147483647 |  |  |  |  |  | 转化
10 | Causes | text | 2147483647 |  |  |  |  |  | 成因
11 | Advice | text | 2147483647 |  |  |  |  |  | 建议方案
12 | ZYAdvice | text | 2147483647 |  |  |  |  |  | 中药辩体保健方案
13 | CareAdivce | text | 2147483647 |  |  |  |  |  | 保健方案
14 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_ChildBodyQA

dbo.YB_ChildBodyQA 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Type | int |  |  |  |  |  |  | 体质类型
3 | NoneValue | int |  |  |  |  |  |  | 没有(根本不)的分数值
4 | LittleValue | int |  |  |  |  |  |  | 很少(有一点)的分数值
5 | SomeValue | int |  |  |  |  |  |  | 有时(有些)的分数值
6 | OftenValue | int |  |  |  |  |  |  | 经常(相当)的分数值
7 | AlWaysValue | int |  |  |  |  |  |  | 总是(非常)的分数值
8 | Content | nvarchar | 200 |  |  |  |  |  | 问题内容
9 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
10 | SameId | uniqueidentifier | 36 |  |  |  | √ |  | 同分数的题目ID
11 | SameType | int |  |  |  |  |  | 0 | 同分数的题目类型


dbo.YB_ChildPhysique

dbo.YB_ChildPhysique 儿童体质 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Type | int |  |  |  |  |  |  | 类型,1-饮食,2-睡眠,3-精神,4-头面,5-口鼻,6-皮肤,7-指甲,8-大小便,9-出汗,10-身高体重
3 | Text | nvarchar | 100 |  |  |  |  |  | 内容
4 | Value | int |  |  |  |  |  |  | 分数
5 | Sort | int |  |  |  |  |  |  | 排序,数字越小越靠前


dbo.YB_ChildPhysiqueResult

dbo.YB_ChildPhysiqueResult 儿童体质结果 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | UserId | int |  |  |  |  |  |  | 用户ID
3 | Score | int |  |  |  |  |  |  | 总分
4 | CreateTime | datetime |  |  |  |  |  |  | 计算时间
5 | FamilyId | int |  |  |  |  |  |  | 家庭成员ID


dbo.YB_ChildPhysiqueResultDetail

dbo.YB_ChildPhysiqueResultDetail 儿童体质结果详情 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | ResultId | uniqueidentifier | 36 |  |  |  |  |  | 记录ID
2 | QId | uniqueidentifier | 36 |  |  |  |  |  | 问答ID


dbo.YB_ChildPrescriptionByAge

dbo.YB_ChildPrescriptionByAge 儿童处方,按年龄 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  | 主键
2 | MinAge | int |  |  |  |  |  |  | 最小年龄,月龄,如果是-1则表示全年龄
3 | MaxAge | int |  |  |  |  |  |  | 最大年龄,月龄,如果是-1则表示全年龄
4 | Type | int |  |  |  |  |  |  | 类型,1-运动,2-睡眠,3-情绪
5 | Content | text | 2147483647 |  |  |  |  |  | 内容


dbo.YB_ChildrenPrescription

dbo.YB_ChildrenPrescription 儿童处方 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Type | int |  |  |  |  |  |  | 类型,1-身高标准,2-BMI标准,3-身高标准
3 | Level | int |  |  |  |  |  |  | 标准,参考处方文档
4 | Nutrition | text | 2147483647 |  |  |  |  |  | 营养,全年龄
5 | Sport | text | 2147483647 |  |  |  |  |  | 运动,全年龄
6 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_Combined

dbo.YB_Combined 平台数据汇总表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ |  |  |  |
2 | TodayRegCnt | int |  |  |  |  |  |  | 今日注册用户数
3 | TotalRegCnt | int |  |  |  |  |  |  | 累计注册用户数
4 | TodayResultCnt | int |  |  |  |  |  |  | 今日称重次数
5 | TotalResultCnt | int |  |  |  |  |  |  | 累计称重次数
6 | TodayDevCnt | int |  |  |  |  |  |  | 今日设备活跃数量
7 | TotalDevCnt | int |  |  |  |  |  |  | 设备总数
8 | TodayIncome | decimal | 18 | 2 |  |  |  |  | 今日收益,单位为分
9 | TotalIncome | decimal | 18 | 2 |  |  |  |  | 累计收益
10 | BusinessCnt | int |  |  |  |  |  | 0 | 客户数量


dbo.YB_DayReport

dbo.YB_DayReport 每日数据统计 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | DayRegCnt | int |  |  |  |  |  |  | 日注册用户数
3 | DayResultCnt | int |  |  |  |  |  |  | 日称重次数
4 | DayDevCnt | int |  |  |  |  |  |  | 日设备活跃数量
5 | DayInCome | decimal | 18 | 2 |  |  |  |  | 日收益,单位为分
6 | RecordTime | date | 10 | 0 |  |  |  |  | 记录时间


dbo.YB_Device

dbo.YB_Device 设备表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  | 设备ID
2 | Name | nvarchar | 100 |  |  |  |  |  | 设备名称
3 | FacCode | varchar | 50 |  |  |  |  |  | 设备序列号,唯一
4 | Ecode | varchar | 50 |  |  |  |  |  | 设备机器码,唯一
5 | Type | int |  |  |  |  |  |  | 设备类型,参考YB_DeviceType表
6 | BusinessId | int |  |  |  |  |  |  | 所属客户ID
7 | Status | int |  |  |  |  |  |  | 设备状态,0-停止运行,1-正常运行,2-待激活
8 | ActiveTime | datetime |  |  |  |  | √ |  | 激活时间
9 | EndTime | datetime |  |  |  |  | √ |  | 到期时间
10 | LastHeartTime | datetime |  |  |  |  | √ |  | 最近测量时间
11 | Remark | nvarchar | 200 |  |  |  |  |  | 备注
12 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
13 | BindBusinessId | int |  |  |  |  |  | 0 |


dbo.YB_DeviceAlloc

dbo.YB_DeviceAlloc 设备分配记录 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | EquId | int |  |  |  |  |  |  | 设备ID
3 | FromBusinessId | int |  |  |  |  |  |  | 分配人
4 | ToBusinessId | int |  |  |  |  |  |  | 接收人
5 | Type | int |  |  |  |  |  |  | 类型,1-出货,2-分配,3-回收,4-激活
6 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_DeviceDayReportData

dbo.YB_DeviceDayReportData 设备日统计数据 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | DayResultCnt | int |  |  |  |  |  |  | 测量次数
3 | DayInCome | decimal | 18 | 2 |  |  |  |  | 收益,分
4 | DevId | int |  |  |  |  |  |  | 设备ID
5 | BusinessId | int |  |  |  |  |  |  | 商户ID
6 | RecordTime | date | 10 | 0 |  |  |  |  | 记录时间


dbo.YB_DeviceType

dbo.YB_DeviceType 设备类型 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Name | nvarchar | 50 |  |  |  |  |  | 类型名称
3 | Code | int |  |  |  |  |  |  | 设备类型编号，1-H01,2-H03
4 | ProType | int |  |  |  |  |  |  | 协议类型,1-身高体重体脂,2-体重体脂
5 | VerType | int |  |  |  |  |  |  | 版本类型,1-基础版,2-高级版,3-婴儿版,4-妈妈版
6 | Remark | nvarchar | 200 |  |  |  |  |  | 备注
7 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
8 | HeadImg | varchar | 100 |  |  |  | √ |  | 封面图片
9 | Content | varchar | 100 |  |  |  | √ |  | 包含的同一类型
10 | ExtName | nvarchar | 50 |  |  |  | √ |  | 类型别名


dbo.YB_DeviceTypeApp

dbo.YB_DeviceTypeApp 小程序绑定的设备类型 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  | 主键
2 | DevType | varchar | 255 |  |  |  |  |  | DevType
3 | AppId | varchar | 255 |  |  |  |  |  | 小程序appid
4 | Status | int |  |  |  |  |  |  | 状态,0-不可用,1-可用
5 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_DeviceTypeExt

dbo.YB_DeviceTypeExt 设备类型对照表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ |  |  |  | 设备类型
2 | RId | int |  |  |  |  |  |  | 映射对应的设备类型,用以多个类型合并到一块
3 | Name | nvarchar | 100 |  |  |  |  |  | 名称
4 | Content | varchar | 255 |  |  |  |  |  | 对应包含的设备类型(同系列),多个中间以英文,分隔
5 | HeadImg | varchar | 100 |  |  |  |  |  | 封面图片
6 | AppId | varchar | 255 |  |  |  |  |  | 小程序appid
7 | Status | int |  |  |  |  |  |  | 状态,0-不可用,1-可用


dbo.YB_EquRealData

dbo.YB_EquRealData 设备合计数据 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | EquId | int |  |  |  |  |  |  | 设备ID
3 | BusinessId | int |  |  |  |  |  |  | 设备所属客户ID
4 | TodayResultCnt | int |  |  |  |  |  |  | 今日称重次数
5 | TotalResultCnt | int |  |  |  |  |  |  | 累计称重数量
6 | TodayInCome | decimal | 18 | 2 |  |  |  |  | 今日收益,单位为分
7 | TotalInCome | decimal | 18 | 2 |  |  |  |  | 累计收益
8 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
9 | TodayRealCnt | int |  |  |  |  |  | 0 | 今日关注数
10 | TotalRealCnt | int |  |  |  |  |  | 0 | 累计关注数


dbo.YB_ErrorLogger

dbo.YB_ErrorLogger 错误日志 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | bigint |  |  | √ |  |  |  |


dbo.YB_ExPress

dbo.YB_ExPress 物流信息 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Name | nvarchar | 50 |  |  |  |  |  | 物流名称
3 | Contact | nvarchar | 50 |  |  |  |  |  | 联系人
4 | Phone | varchar | 20 |  |  |  |  |  | 联系电话
5 | Remark | nvarchar | 200 |  |  |  |  |  | 备注
6 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_Family

dbo.YB_Family 家庭成员 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | HeadImg | varchar | 200 |  |  |  |  |  | 头像地址
3 | Type | int |  |  |  |  |  |  | 类型,1-成人,2-儿童
4 | Name | nvarchar | 100 |  |  |  |  |  | 名称
5 | Height | decimal | 10 | 2 |  |  |  |  | 身高,单位为厘米
6 | Sex | int |  |  |  |  |  |  | 性别,0-未知,1-男,2-女
7 | Weight | decimal | 18 | 2 |  |  |  |  | 体重,单位为kg
8 | Birthday | date | 10 | 0 |  |  |  |  | 生日,出生年月日
9 | Age | int |  |  |  |  |  |  | 年龄,岁
10 | Status | int |  |  |  |  |  |  | 状态,0-禁用,1-启用
11 | UserId | int |  |  |  |  |  |  | 所属的用户ID
12 | IsSelf | int |  |  |  |  |  |  | 是否为自己,0-否,1-是,不能够删除
13 | LastHeartTime | datetime |  |  |  |  | √ |  | 最近的测量时间
14 | Createtime | datetime |  |  |  |  |  |  | 创建时间
15 | Head | decimal | 18 | 2 |  |  |  | 0 | 头围,厘米


dbo.YB_FamilyData

dbo.YB_FamilyData 家庭成员数据,针对全设备类型 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | FamilyId | int |  |  | √ |  |  |  | 家庭成员ID
2 | DadHeight | decimal | 10 | 2 |  |  |  |  | 爸爸身高
3 | MomHeight | decimal | 10 | 2 |  |  |  |  | 妈妈身高
4 | AdultHeight | decimal | 10 | 2 |  |  |  |  | 成年之后的身高预测
5 | HalfYearHeight | decimal | 10 | 2 |  |  |  |  | 半年前的身高
6 | YearHeight | decimal | 10 | 2 |  |  |  |  | 一年前的身高
7 | CreateTime | datetime |  |  |  |  |  |  | 编码
8 | TotalCount | int |  |  |  |  |  | 0 | 累计测量次数
9 | TodayCount | int |  |  |  |  |  | 0 | 今日测量次数
10 | FirstHeight | decimal | 10 | 2 |  |  |  | 0 | 第一次测量身高
11 | FirstWeight | decimal | 18 | 2 |  |  |  | 0 | 第一次测量的体重
12 | LastWeight | decimal | 18 | 2 |  |  |  | 0 | 最近一次测量体重
13 | LastHeight | decimal | 10 | 2 |  |  |  | 0 | 最近一次身高
14 | LastResultTime | datetime |  |  |  |  | √ |  | 最近一次体重测量时间
15 | FirstResultTime | datetime |  |  |  |  | √ |  | 第一次测量时间
16 | LastTimeWeight | decimal | 18 | 2 |  |  |  | 0 | 较上次的体重变化,上一次减去本次
17 | LastTimeHeight | decimal | 10 | 2 |  |  |  | 0 | 较上次的身高变化,上次减去本次
18 | LastResultHeightTime | datetime |  |  |  |  | √ |  | 最近一次身高测量时间
19 | LastHead | decimal | 10 | 2 |  |  | √ |  | 最近一次头围


dbo.YB_FamilyRealData

dbo.YB_FamilyRealData 家庭成员实时数据 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | FamilyId | int |  |  |  |  |  |  | 家庭成员ID
3 | UserId | int |  |  |  |  |  |  | 用户ID
4 | FirstWeight | decimal | 18 | 2 |  |  |  |  | 初始体重
5 | DevType | int |  |  |  |  |  |  | 设备类型
6 | TotalCount | int |  |  |  |  |  |  | 累计测量次数
7 | TodayCount | int |  |  |  |  |  |  | 今日测量次数
8 | FirstHeight | decimal | 18 | 2 |  |  |  |  | 第一次测量身高
9 | LastWeight | decimal | 18 | 2 |  |  |  |  | 最近一次测量体重
10 | LastHeight | decimal | 18 | 2 |  |  |  |  | 最近一次身高
11 | LastResultTime | datetime |  |  |  |  | √ |  | 最近一次测量时间
12 | FirstResultTime | datetime |  |  |  |  | √ |  | 第一次测量时间
13 | LastTimeWeight | decimal | 18 | 2 |  |  |  |  | 较上次的体重变化,上一次减去本次
14 | LastTimeHeight | decimal | 18 | 2 |  |  |  |  | 较上次的身高变化,上次减去本次
15 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
16 | LastResultHeightTime | datetime |  |  |  |  | √ |  | 最近一次身高测量时间
17 | MonthHeight | decimal | 18 | 2 |  |  | √ |  | 本月最高身高值,厘米
18 | MonthWeight | decimal | 18 | 2 |  |  | √ |  | 本月最新体重值,公斤
19 | LastResultId | uniqueidentifier | 36 |  |  |  | √ |  | 最近一次测量记录ID
20 | HalfYearHeight | decimal | 10 | 2 |  |  | √ |  | 半年前的身高
21 | YearHeight | decimal | 10 | 2 |  |  | √ |  | 一年前的身高
22 | HalfYearHeightTime | datetime |  |  |  |  | √ |  | 半年前的身高记录时间
23 | YearHeightTime | datetime |  |  |  |  | √ |  | 一年前的身高记录时间
24 | LastHead | decimal | 18 | 2 |  |  | √ |  | 最近一次头围
25 | MonthHead | decimal | 18 | 2 |  |  | √ | 0 | 本月最新头围,CM


dbo.YB_FamilyReportData

dbo.YB_FamilyReportData 家庭成员统计数据,按月统计,去每月的最高体重和身高 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | FamilyId | int |  |  |  |  |  |  | 家庭成员ID
3 | Height | decimal | 6 | 2 |  |  |  |  | 身高,CM
4 | Weight | decimal | 6 | 2 |  |  |  |  | 体重,KG
5 | CreateTime | date | 10 | 0 |  |  |  |  | 统计时间
6 | DevType | int |  |  |  |  |  | 0 | 设备类型
7 | LastWeightTime | datetime |  |  |  |  | √ |  | 月度最近体重的测量时间
8 | Head | decimal | 6 | 2 |  |  |  | 0 | 头围,CM


dbo.YB_FamilyTarget

dbo.YB_FamilyTarget 家庭成员目标体重 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | familyid | int |  |  |  |  |  |  | 家庭成员ID
3 | time | date | 10 | 0 |  |  |  |  | 目标日期
4 | weight | decimal | 18 | 2 |  |  |  |  | 目标体重


dbo.YB_HeadStand

dbo.YB_HeadStand 头围标准 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Month | decimal | 6 | 2 |  |  |  |  | 月龄
3 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女
4 | f3sd | decimal | 4 | 1 |  |  |  |  | -3SD
5 | f2sd | decimal | 4 | 1 |  |  |  |  | 2SD
6 | f1sd | decimal | 4 | 1 |  |  |  |  | 1SD
7 | median | decimal | 4 | 1 |  |  |  |  | 中位数
8 | z1sd | decimal | 4 | 1 |  |  |  |  | 1SD
9 | z2sd | decimal | 4 | 1 |  |  |  |  | 2SD
10 | z3sd | decimal | 4 | 1 |  |  |  |  | 3SD


dbo.YB_HeightStand

dbo.YB_HeightStand 身高标准 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Month | int |  |  |  |  |  |  | 月龄
3 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女
4 | f3sd | decimal | 4 | 1 |  |  |  |  | -3SD
5 | f2sd | decimal | 4 | 1 |  |  |  |  | -2SD
6 | f1sd | decimal | 4 | 1 |  |  |  |  | -1SD
7 | median | decimal | 4 | 1 |  |  |  |  | 中位数
8 | z1sd | decimal | 4 | 1 |  |  |  |  | +1SD
9 | z2sd | decimal | 4 | 1 |  |  |  |  | +2SD
10 | z3sd | decimal | 4 | 1 |  |  |  |  | +3SD


dbo.YB_LXBodyAns

dbo.YB_LXBodyAns 丽秀体质提交的问卷 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Score | int |  |  |  |  |  |  | 得分
3 | RealScore | int |  |  |  |  |  |  | 转化分
4 | UserId | int |  |  |  |  |  |  | 用户ID
5 | FamilyId | int |  |  |  |  |  |  | 家庭成员ID
6 | TypeId | uniqueidentifier | 36 |  |  |  |  |  | 体质ID
7 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_LXBodyGuide

dbo.YB_LXBodyGuide 丽秀中医指导 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | TypeId | uniqueidentifier | 36 |  |  |  |  |  | 体质ID
3 | Feature | nvarchar | 100 |  |  |  |  |  | 特征
4 | People | nvarchar | 100 |  |  |  |  |  | 重点人群
5 | Sick | nvarchar | 100 |  |  |  |  |  | 患病倾向
6 | Health | nvarchar | 100 |  |  |  |  |  | 调养方式
7 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_LXBodyQA

dbo.YB_LXBodyQA 丽秀体质问题 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Title | nvarchar | 100 |  |  |  |  |  | 问题
3 | SortCode | int |  |  |  |  |  |  | 排序,数字越小越靠前
4 | TypeId | uniqueidentifier | 36 |  |  |  |  |  | 体质ID
5 | NoneValue | int |  |  |  |  |  |  | 没有(根本不)的分数值
6 | LittleValue | int |  |  |  |  |  |  | 很少(有一点)的分数值
7 | SomeValue | int |  |  |  |  |  |  | 有时(有些)的分数值
8 | OftenValue | int |  |  |  |  |  |  | 经常(相当)的分数值
9 | AlWaysValue | int |  |  |  |  |  |  | 总是(非常)的分数值
10 | IsRequired | int |  |  |  |  |  |  | 分数需要逆向转换
11 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
12 | IsSex | int |  |  |  |  |  |  | 是否关联性别,1-男,2-女,0-未知


dbo.YB_LXBodyResult

dbo.YB_LXBodyResult 丽秀体质提交的问卷结果 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | TypeId | uniqueidentifier | 36 |  |  |  |  |  | 体质ID
3 | BodyType | nvarchar | 50 |  |  |  |  |  | 体质类型
4 | Result | int |  |  |  |  |  |  | 判定结果,1-是,2-基本是,3-否
5 | UserId | int |  |  |  |  |  |  | 用户ID
6 | FamilyId | int |  |  |  |  |  |  | 家庭成语ID
7 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_LXBodyType

dbo.YB_LXBodyType 丽秀体质类型 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Name | nvarchar | 50 |  |  |  |  |  | 体质名称
3 | IsPH | int |  |  |  |  |  |  | 是否为平和质,1-是,0-否
4 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_Measure

dbo.YB_Measure 测量记录计算结果 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | ResultId | int |  |  |  |  |  |  | 测量记录ID
3 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女,0-未知
4 | Age | int |  |  |  |  |  |  | 年龄,岁
5 | Month | int |  |  |  |  |  |  | 年龄月份
6 | Height | decimal | 18 | 2 |  |  |  |  | 身高,单位为CM
7 | Weight | decimal | 18 | 2 |  |  |  |  | 体重
8 | FamilyId | int |  |  |  |  |  |  | 分配给的家庭成员ID
9 | fat_r | decimal | 18 | 2 |  |  |  |  | 脂肪率
10 | muscle | decimal | 18 | 2 |  |  |  |  | 肌肉率
11 | water | decimal | 18 | 2 |  |  |  |  | 水份
12 | bone | decimal | 18 | 2 |  |  |  |  | 骨重
13 | kcal | decimal | 18 | 2 |  |  |  |  | 基础代谢
14 | fat_w | decimal | 18 | 2 |  |  |  |  | 脂肪重量
15 | visceral | decimal | 18 | 2 |  |  |  |  | 内脂
16 | protein | decimal | 18 | 2 |  |  |  |  | 蛋白质
17 | bodyage | int |  |  |  |  |  |  | 体龄
18 | bmi | decimal | 18 | 2 |  |  |  |  | BMI
19 | cmi | decimal | 18 | 2 |  |  |  |  | 分数
20 | sfr | decimal | 18 | 2 |  |  |  |  | 皮下脂肪
21 | muscleval | decimal | 18 | 2 |  |  |  |  | 肌肉量
22 | proteinval | decimal | 18 | 2 |  |  |  |  | 蛋白量
23 | lbm | decimal | 18 | 2 |  |  |  |  | 去脂体重
24 | body | varchar | 50 |  |  |  |  |  | 体型,参考体型枚举
25 | fatlevel | varchar | 50 |  |  |  |  |  | 肥胖等级,参考等级枚举
26 | createtime | datetime |  |  |  |  |  |  | 计算时间
27 | Type | int |  |  |  |  |  | 1 | 类型,1-单阻抗,2-八电极
28 | TakeStatus | int |  |  |  |  |  | 1 | 计费状态,0-未领取,1-已领取,-1-未知状态,2-重复领取


dbo.YB_Menu

dbo.YB_Menu 菜单表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Name | nvarchar | 50 |  |  |  |  |  | 菜单名称
3 | Url | varchar | 100 |  |  |  |  |  | 菜单地址
4 | Icon | varchar | 100 |  |  |  |  |  | 图标,阿里图标
5 | SortCode | int |  |  |  |  |  |  | 排序,数字越小越靠前
6 | ParentId | int |  |  |  |  |  |  | 上级ID
7 | Remark | nvarchar | 200 |  |  |  |  |  | 备注
8 | Status | int |  |  |  |  |  |  | 状态,0-禁用,1-启用
9 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_MiniProgramHistory

dbo.YB_MiniProgramHistory 小程序提交审核记录 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | appid | varchar | 50 |  |  |  |  |  | 公众号appid
3 | UserVersion | varchar | 100 |  |  |  |  |  | 代码版本号，开发者可自定义（长度不要超过 64 个字符）
4 | UserDesc | nvarchar | 100 |  |  |  |  |  | 代码描述，开发者可自定义
5 | Status | int |  |  |  |  |  |  | 审核状态,-1-代码已上传,0-审核成功,1-审核被拒绝,2-审核中,3-已撤回,4-审核延后
6 | StatusRemark | nvarchar | -1 |  |  |  | √ |  | 当审核被拒绝时，返回的拒绝原因
7 | auditid | varchar | 50 |  |  |  |  |  | 最新的审核 ID
8 | ScreenShot | varchar | -1 |  |  |  | √ |  | 当审核被拒绝时，会返回审核失败的小程序截图示例。用 | 分隔的 media_id 的列表，可通过获取永久素材接口拉取截图内容
9 | LastTime | datetime |  |  |  |  | √ |  | 最近修改时间
10 | CreateTime | datetime |  |  |  |  |  |  | 上传时间


dbo.YB_MiniPrograms

dbo.YB_MiniPrograms 小程序列表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Name | nvarchar | 50 |  |  |  |  |  | 小程序名称
3 | Appid | varchar | 50 |  |  |  |  |  | 小程序appid
4 | AppSecret | varchar | 50 |  |  |  |  |  | 小程序密钥
5 | QrCode | varchar | 200 |  |  |  |  |  | 二维码链接地址
6 | Status | int |  |  |  |  |  |  | 状态,0-禁用,1-启用
7 | Remark | nvarchar | 200 |  |  |  |  |  | 备注
8 | BusinessId | int |  |  |  |  |  |  | 所属的客户ID
9 | LastModifyTime | datetime |  |  |  |  |  |  | 最近修改时间
10 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_MiniProgramsDraft

dbo.YB_MiniProgramsDraft 小程序草稿 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | DraftId | int |  |  |  |  |  |  | 草稿 id
3 | UserVersion | varchar | 100 |  |  |  |  |  | 版本号，开发者自定义字段
4 | UserDesc | nvarchar | 200 |  |  |  |  |  | 版本描述 开发者自定义字段
5 | CreateTime | datetime |  |  |  |  |  |  | 上传时间
6 | SyncTime | datetime |  |  |  |  |  |  | 同步时间


dbo.YB_MiniProgramsTpl

dbo.YB_MiniProgramsTpl 小程序模版 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | TemplateId | int |  |  |  |  |  |  | 模板 id
3 | UsrVersion | varchar | 100 |  |  |  |  |  | 模板版本号，开发者自定义字段
4 | UserDesc | nvarchar | 200 |  |  |  |  |  | 模板描述，开发者自定义字段
5 | CreateTime | datetime |  |  |  |  |  |  | 被添加为模板的时间
6 | SyncTime | datetime |  |  |  |  |  |  | 同步时间


dbo.YB_MiniProgramSubscribeMessageTpl

dbo.YB_MiniProgramSubscribeMessageTpl 小程序订阅消息模板列表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | AppId | varchar | 50 |  |  |  |  |  | 小程序appid
3 | PriTmplId | varchar | 100 |  |  |  |  |  | 添加至帐号下的模板 id，发送小程序订阅消息时所需
4 | Title | nvarchar | 50 |  |  |  |  |  | 模板标题
5 | Content | nvarchar | 100 |  |  |  |  |  | 模版内容
6 | KeyWords | varchar | 100 |  |  |  |  |  | 模板关键字列表,多个以|分隔
7 | Example | nvarchar | 200 |  |  |  |  |  | 模板关键字对应的值,多个以|分隔
8 | Type | int |  |  |  |  |  |  | 模板类型,2-一次性订阅,3-长期订阅
9 | IsSelected | bit | 1 |  |  |  |  |  | 是否选取,true-是,false-否
10 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_nBodyMeasure

dbo.YB_nBodyMeasure 八电极标准数据 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | LevelJson | nvarchar | -1 |  |  |  |  |  | 等级标准


dbo.YB_NewHeightStand

dbo.YB_NewHeightStand 新的身高标准 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Month | decimal | 6 | 2 |  |  |  |  | 月龄
3 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女
4 | f3sd | decimal | 4 | 1 |  |  |  |  | -3SD
5 | f2sd | decimal | 4 | 1 |  |  |  |  | 2SD
6 | f1sd | decimal | 4 | 1 |  |  |  |  | 1SD
7 | median | decimal | 4 | 1 |  |  |  |  | 中位数
8 | z1sd | decimal | 4 | 1 |  |  |  |  | 1SD
9 | z2sd | decimal | 4 | 1 |  |  |  |  | 2SD
10 | z3sd | decimal | 4 | 1 |  |  |  |  | 3SD


dbo.YB_NewWeightStand

dbo.YB_NewWeightStand 新的体重标准 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Month | decimal | 6 | 2 |  |  |  |  | 月龄
3 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女
4 | f3sd | decimal | 4 | 1 |  |  |  |  | -3SD
5 | f2sd | decimal | 4 | 1 |  |  |  |  | 2SD
6 | f1sd | decimal | 4 | 1 |  |  |  |  | 1SD
7 | median | decimal | 4 | 1 |  |  |  |  | 中位数
8 | z1sd | decimal | 4 | 1 |  |  |  |  | 1SD
9 | z2sd | decimal | 4 | 1 |  |  |  |  | 2SD
10 | z3sd | decimal | 4 | 1 |  |  |  |  | 3SD


dbo.YB_nMeasureResult

dbo.YB_nMeasureResult 用户计算结果 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | DevType | int |  |  |  |  |  |  | 设备类型,参考类型表
3 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女,0-未知
4 | Age | int |  |  |  |  |  |  | 年龄,岁
5 | Month | int |  |  |  |  |  |  | 年龄月份
6 | Height | decimal | 18 | 2 |  |  |  |  | 身高,单位为CM
7 | Weight | decimal | 18 | 2 |  |  |  |  | 体重
8 | fat_r | decimal | 18 | 2 |  |  |  |  | 脂肪率
9 | muscle | decimal | 18 | 2 |  |  |  |  | 肌肉率
10 | water | decimal | 18 | 2 |  |  |  |  | 水份
11 | bone | decimal | 18 | 2 |  |  |  |  | 骨重
12 | kcal | decimal | 18 | 2 |  |  |  |  | 基础代谢
13 | fat_w | decimal | 18 | 2 |  |  |  |  | 脂肪重量
14 | visceral | decimal | 18 | 2 |  |  |  |  | 内脂
15 | protein | decimal | 18 | 2 |  |  |  |  | 蛋白质
16 | bodyage | decimal | 18 | 2 |  |  |  |  | 体龄
17 | bmi | decimal | 18 | 2 |  |  |  |  | BMI
18 | cmi | decimal | 18 | 2 |  |  |  |  | 分数
19 | sfr | decimal | 18 | 2 |  |  |  |  | 皮下脂肪
20 | muscleval | decimal | 18 | 2 |  |  |  |  | 肌肉量
21 | proteinval | decimal | 18 | 2 |  |  |  |  | 阻蛋白量抗值
22 | lbm | decimal | 18 | 2 |  |  |  |  | 去脂体重
23 | body | nvarchar | 50 |  |  |  |  |  | 体型,参考体型枚举
24 | fatlevel | nvarchar | 50 |  |  |  |  |  | 肥胖等级,参考等级枚举
25 | BodyMuscle | decimal | 18 | 2 |  |  |  |  | 躯干肌肉率
26 | LeftFootMuscle | decimal | 18 | 2 |  |  |  |  | 左脚肌肉率
27 | RightFootMuscle | decimal | 18 | 2 |  |  |  |  | 右脚肌肉率
28 | LeftHandMuscle | decimal | 18 | 2 |  |  |  |  | 左手肌肉率
29 | RightHandMuscle | decimal | 18 | 2 |  |  |  |  | 右手肌肉率
30 | BodyFat | decimal | 18 | 2 |  |  |  |  | 躯干脂肪率
31 | LeftFootFat | decimal | 18 | 2 |  |  |  |  | 左脚脂肪率
32 | RightFootFat | decimal | 18 | 2 |  |  |  |  | 右脚脂肪率
33 | LeftHandFat | decimal | 18 | 2 |  |  |  |  | 左手脂肪率
34 | RightHandFat | decimal | 18 | 2 |  |  |  |  | 右手脂肪率
35 | BodyMuscleVal | decimal | 18 | 2 |  |  |  |  | 躯干肌肉量
36 | LeftFootMuscleVal | decimal | 18 | 2 |  |  |  |  | 左脚肌肉量
37 | RightFootMuscleVal | decimal | 18 | 2 |  |  |  |  | 右脚肌肉量
38 | LeftHandMuscleVal | decimal | 18 | 2 |  |  |  |  | 左手肌肉量
39 | RightHandMuscleVal | decimal | 18 | 2 |  |  |  |  | 右手肌肉量
40 | BodyFatVal | decimal | 18 | 2 |  |  |  |  | 躯干脂肪量
41 | LeftFootFatVal | decimal | 18 | 2 |  |  |  |  | 左脚脂肪量
42 | RightFootFatVal | decimal | 18 | 2 |  |  |  |  | 右脚脂肪量
43 | LeftHandFatVal | decimal | 18 | 2 |  |  |  |  | 左手脂肪量
44 | RightHandFatVal | decimal | 18 | 2 |  |  |  |  | 右手脂肪量
45 | SfrVal | decimal | 18 | 2 |  |  |  |  | 皮下脂肪量,kg
46 | IdealWeight | decimal | 18 | 2 |  |  |  |  | 理想体重
47 | SkeletalMuscle | decimal | 18 | 2 |  |  |  |  | 骨骼肌量,kg
48 | createtime | datetime |  |  |  |  |  |  | 计算时间
49 | Head | decimal | 18 | 2 |  |  | √ |  | 头围


dbo.YB_nMenu

dbo.YB_nMenu 菜单表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Name | nvarchar | 50 |  |  |  |  |  | 菜单名称
3 | Url | varchar | 100 |  |  |  |  |  | 菜单地址
4 | Icon | varchar | 100 |  |  |  |  |  | 图标,阿里图标
5 | SortCode | int |  |  |  |  |  |  | 排序,数字越小越靠前
6 | ParentId | uniqueidentifier | 36 |  |  |  |  |  | 上级ID
7 | Remark | nvarchar | 200 |  |  |  |  |  | 备注
8 | Status | int |  |  |  |  |  |  | 状态,0-禁用,1-启用
9 | IsSuper | int |  |  |  |  |  |  | 是否只有超级管理员能够查看,0-否,1-是
10 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_nMenuAction

dbo.YB_nMenuAction 菜单按钮 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  | 记录ID
2 | MenuId | uniqueidentifier | 36 |  |  |  |  |  | 菜单ID
3 | ButtonId | varchar | 50 |  |  |  |  |  | 按钮ID
4 | ButtonName | nvarchar | 50 |  |  |  |  |  | 按钮名称
5 | Type | int |  |  |  |  | √ |  | 位置,1-上部,2-表格头,3-表格列
6 | ControlName | varchar | 50 |  |  |  |  |  | 控制器名称
7 | ActionName | varchar | 50 |  |  |  |  |  | 方法名称
8 | SortCode | int |  |  |  |  |  |  | 排序,数字越小越靠前


dbo.YB_NoticeLog

dbo.YB_NoticeLog 通知日志 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Ip | varchar | 50 |  |  |  |  |  | IP地址
3 | UA | varchar | -1 |  |  |  |  |  | UA信息
4 | Info | nvarchar | -1 |  |  |  |  |  | 参数额外信息
5 | UserInfo | nvarchar | -1 |  |  |  |  |  | 用户信息
6 | FromInfo | varchar | 100 |  |  |  |  |  | 来源
7 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_NoticeLogger

dbo.YB_NoticeLogger 通知日志 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Ip | varchar | 100 |  |  |  |  |  | 来IP地址源
3 | UA | varchar | -1 |  |  |  |  |  | UA信息
4 | Info | nvarchar | -1 |  |  |  |  |  | 参数额外信息
5 | UserInfo | nvarchar | -1 |  |  |  |  |  | 用户信息
6 | FromInfo | nvarchar | -1 |  |  |  |  |  | 来源
7 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_nResult

dbo.YB_nResult 测量记录 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Height | decimal | 18 | 2 |  |  |  |  | 身高，单位厘米
3 | Weight | decimal | 18 | 2 |  |  |  |  | 体重,单位kg
4 | BusinessId | int |  |  |  |  |  |  | 设备所属商户ID
5 | EquId | int |  |  |  |  |  |  | 设备ID
6 | DevType | int |  |  |  |  |  |  | 设备类型,参考类型表
7 | SourceType | int |  |  |  |  |  |  | 来源,1-蓝牙传输,2-手动记录,3-扫码记录
8 | Imp | decimal | 18 | 2 |  |  |  |  | 阻抗值
9 | LeftArmImp | decimal | 18 | 2 |  |  |  |  | 左手阻抗
10 | RightArmImp | decimal | 18 | 2 |  |  |  |  | 右手阻抗
11 | LeftLegImp | decimal | 18 | 2 |  |  |  |  | 左脚阻抗
12 | RightLegImp | decimal | 18 | 2 |  |  |  |  | 右脚阻抗
13 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_nResultAdd

dbo.YB_nResultAdd 手动添加的记录 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Height | decimal | 18 | 2 |  |  |  |  | 身高，单位厘米
3 | Weight | decimal | 18 | 2 |  |  |  |  | 体重,单位kg
4 | FamilyId | int |  |  |  |  |  |  | 家庭成员ID
5 | UserId | int |  |  |  |  |  |  | 用户ID
6 | ResultTime | datetime |  |  |  |  |  |  | 测量时间
7 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
8 | Head | decimal | 18 | 2 |  |  | √ |  | 头围,单位cm


dbo.YB_nRole

dbo.YB_nRole 角色表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Name | nvarchar | 50 |  |  |  |  |  | 角色名称
3 | Code | varchar | 50 |  |  |  |  |  | 角色编号
4 | Remark | nvarchar | 200 |  |  |  |  |  | 角色备注
5 | Status | int |  |  |  |  |  |  | 状态,0-禁用,1-启用
6 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_nRoleAction

dbo.YB_nRoleAction 角色按钮 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | RoleId | uniqueidentifier | 36 |  |  |  |  |  | 角色ID
2 | MenuId | uniqueidentifier | 36 |  |  |  |  |  | 菜单ID
3 | ButtonId | uniqueidentifier | 36 |  |  |  |  |  | 按钮ID


dbo.YB_nRoleMenu

dbo.YB_nRoleMenu 角色菜单表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | RoleId | uniqueidentifier | 36 |  |  |  |  |  | 角色ID
3 | MenuId | uniqueidentifier | 36 |  |  |  |  |  | 菜单ID
4 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_nSecInfo

dbo.YB_nSecInfo 科普资讯 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Type | int |  |  |  |  |  |  | 类型,1-文本,2-链接,3-跳转小程序
3 | Title | nvarchar | 100 |  |  |  |  |  | 标题
4 | TagId | int |  |  |  |  |  |  | 所属分组ID
5 | HeadImg | varchar | 100 |  |  |  |  |  | 标题
6 | ClickCount | int |  |  |  |  |  |  | 点击次数
7 | Status | int |  |  |  |  |  |  | 状态,0-未开启,1-正常运行,2-已关闭
8 | StatusRemark | nvarchar | 50 |  |  |  |  |  | 状态备注
9 | BusienssId | int |  |  |  |  |  |  | 商户ID
10 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_nSecInfoAppId

dbo.YB_nSecInfoAppId 科普资讯appid 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | InfoId | uniqueidentifier | 36 |  |  |  |  |  | 资讯ID
2 | AppId | varchar | 50 |  |  |  | √ |  | 小程序appid


dbo.YB_nSecInfoContent

dbo.YB_nSecInfoContent 科普资讯内容 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | InfoId | uniqueidentifier | 36 |  |  |  |  |  | 资讯ID
2 | Content | text | 2147483647 |  |  |  |  |  | 内容


dbo.YB_nUserResult

dbo.YB_nUserResult 测量记录扩展 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | FansId | uniqueidentifier | 36 |  |  |  | √ |  | 粉丝ID
3 | DevType | int |  |  |  |  |  |  | 设备类型
4 | FamilyId | int |  |  |  |  |  |  | 家庭成员ID
5 | UserId | int |  |  |  |  |  |  | 用户ID
6 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
7 | Status | int |  |  |  |  | √ | 1 | 记录状态,1-正常,0-删除


dbo.YB_OfficlaAccount

dbo.YB_OfficlaAccount 微信公众号 小程序 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | type | int |  |  |  |  |  |  | 类型,1-公众号,2-小程序
3 | authorizer_appid | varchar | 50 |  |  |  |  |  | 微信appid
4 | componentappid | varchar | 50 |  |  |  |  |  | 微信开放平台appid
5 | authorizer_access_token | varchar | 300 |  |  |  |  |  | 授权token
6 | authorizer_refresh_token | varchar | 200 |  |  |  |  |  | 刷新token
7 | head_img | varchar | 300 |  |  |  |  |  | 头像地址
8 | nick_name | nvarchar | 50 |  |  |  |  |  | 昵称
9 | user_name | varchar | 50 |  |  |  |  |  | 原始ID
10 | alias | varchar | 50 |  |  |  |  |  | 别名
11 | service_type_info | nvarchar | 50 |  |  |  |  |  | 公众号类型
12 | verify_type_info | nvarchar | 50 |  |  |  |  |  | 认证类型
13 | func_info | nvarchar | -1 |  |  |  |  |  |
14 | qrcode_url | varchar | 200 |  |  |  |  |  | 二维码地址
15 | isauthorize | int |  |  |  |  |  |  | 授权状态,0-未授权,1-已授权
16 | lastmodifytime | datetime |  |  |  |  |  |  | 更新时间
17 | authorizeationcode | varchar | 100 |  |  |  |  |  | 授权码
18 | authorizationcodeexpiredtime | datetime |  |  |  |  | √ |  | 授权码过期时间
19 | createtime | datetime |  |  |  |  |  |  | 授权时间


dbo.YB_OpenWXConfig

dbo.YB_OpenWXConfig 微信开放平台配置 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | ComponentAppId | varchar | 50 |  | √ |  |  |  | 开放平台APPID
2 | OpenTicket | varchar | 500 |  |  |  |  |  | ticket


dbo.YB_Order

dbo.YB_Order 设备订单,适用于扫码关注流程 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Name | nvarchar | 50 |  |  |  |  |  | 订单名称
3 | Type | int |  |  |  |  |  |  | 内容类型,1-公众号,2-链接,3-小程序
4 | Url | varchar | 200 |  |  |  |  |  | 链接或者公众号appid
5 | Page | varchar | 100 |  |  |  |  |  | 当为小程序时的跳转页面地址
6 | RealCount | int |  |  |  |  |  |  | 实时关注/点击数
7 | ShowCount | int |  |  |  |  |  |  | 累计展现次数
8 | TotalCount | int |  |  |  |  |  |  | 总数,为0则无上限
9 | DayCount | int |  |  |  |  |  |  | 今日展现数量
10 | DayRealCount | int |  |  |  |  |  |  | 今日实际关注/点击数
11 | DayLimit | int |  |  |  |  |  |  | 日上限,为0则没有上限
12 | StartTime | datetime |  |  |  |  | √ |  | 开始时间,为空则马上开始
13 | EndTime | datetime |  |  |  |  | √ |  | 结束时间,为空则不会结束
14 | Status | int |  |  |  |  |  |  | 订单状态,1-正常,2-暂停,3-已完成,4-已取消
15 | StatusRemark | varchar | 255 |  |  |  |  |  | 状态备注
16 | Priority | int |  |  |  |  |  |  | 优先级,数字越大越先被取到
17 | BusinessId | int |  |  |  |  |  |  | 商户ID
18 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
19 | OrderType | int |  |  |  |  | √ | '2' | 订单类型,1-设备管理,2-用户测量


dbo.YB_OrderEqu

dbo.YB_OrderEqu 订单绑定的设备 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | OrderId | uniqueidentifier | 36 |  |  |  |  |  | 订单ID
2 | EquId | int |  |  |  |  |  |  | 设备ID


dbo.YB_OutProduct

dbo.YB_OutProduct 出货系统 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Type | int |  |  |  |  |  |  | 出货类型,1-出货,2-退货
3 | PayType | int |  |  |  |  |  |  | 支付类型,1-发货付款,2-到付
4 | DevType | int |  |  |  |  |  |  | 设备类型,参考设备类型表
5 | Express | int |  |  |  |  |  |  | 快递公司
6 | ExpressNo | varchar | 50 |  |  |  |  |  | 快递单号
7 | ExpressAmount | decimal | 18 | 2 |  |  |  |  | 物流费用
8 | BusinessId | int |  |  |  |  |  |  | 服务商ID
9 | Cnt | int |  |  |  |  |  |  | 设备数量
10 | Sender | nvarchar | 50 |  |  |  |  |  | 发件人
11 | SenderPhone | varchar | 20 |  |  |  |  |  | 发件人电话
12 | SenderAddress | nvarchar | 200 |  |  |  |  |  | 发送地址
13 | Recver | nvarchar | 50 |  |  |  |  |  | 收件人
14 | RecverPhone | varchar | 20 |  |  |  |  |  | 收件电话
15 | RecverAdderess | nvarchar | 200 |  |  |  |  |  | 收货地址
16 | SenderRemark | nvarchar | 200 |  |  |  |  |  | 发货备注
17 | RecverRemark | nvarchar | 200 |  |  |  |  |  | 收货备注
18 | CancelRemark | nvarchar | 200 |  |  |  |  |  | 取消原因
19 | RecvTime | datetime |  |  |  |  | √ |  | 收货时间
20 | SendTime | datetime |  |  |  |  | √ |  | 发货时间
21 | Status | int |  |  |  |  |  |  | 状态,0-已下单,1-设备已打包,2-已发货,3-运送中,4-已收货,5-取消
22 | FilePath | varchar | 100 |  |  |  |  |  | 上传的设备文件
23 | FailPath | varchar | 100 |  |  |  |  |  | 上传失败的文件
24 | CreateTime | datetime |  |  |  |  |  |  | 下单时间


dbo.YB_OutProductDev

dbo.YB_OutProductDev 出货订单对应的设备 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | OrderId | int |  |  |  |  |  |  | 出货订单ID
2 | DeviceId | int |  |  |  |  |  |  | 设备id
3 | DeviceCode | varchar | 50 |  |  |  |  |  | 设备编号


dbo.YB_PrintCode

dbo.YB_PrintCode 打印编码 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_PrintCodeEqu

dbo.YB_PrintCodeEqu 打印编码对应的设备 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | PrintId | uniqueidentifier | 36 |  |  |  |  |  | 打印编码对应的id
2 | FacEcode | varchar | 255 |  |  |  |  |  | 设备编号


dbo.YB_RegUser

dbo.YB_RegUser 注册用户表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Name | nvarchar | 100 |  |  |  |  |  | 昵称
3 | Phone | varchar | 20 |  |  |  |  |  | 手机号
4 | Headimg | varchar | 200 |  |  |  |  |  | 头像
5 | Country | nvarchar | 100 |  |  |  |  |  | 国家
6 | Province | nvarchar | 100 |  |  |  |  |  | 省份
7 | City | nvarchar | 100 |  |  |  |  |  | 城市
8 | Gender | int |  |  |  |  |  |  | 性别,0-未知,1-男,2-女
9 | Secret | varchar | 50 |  |  |  |  |  | 密码的密钥
10 | Password | varchar | 50 |  |  |  |  |  | 密码
11 | Status | int |  |  |  |  |  |  | 状态,0-禁用,1-启用
12 | LastVisitTime | datetime |  |  |  |  |  |  | 最近访问时间
13 | LastVisitIP | varchar | 50 |  |  |  |  |  | 最近访问IP
14 | UnionId | varchar | 50 |  |  |  |  |  | 用户唯一标识
15 | CreateTime | datetime |  |  |  |  |  |  | 注册时间
16 | FansId | uniqueidentifier | 36 |  |  |  | √ |  | 关联的粉丝ID


dbo.YB_Result

dbo.YB_Result 测量记录 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Weight | decimal | 18 | 2 |  |  |  |  | 体重,单位kg
3 | Height | decimal | 10 | 2 |  |  |  |  | 身高,单位厘米
4 | Imp | decimal | 18 | 2 |  |  |  |  | 阻抗,单位欧姆
5 | TaskStatus | int |  |  |  |  |  |  | 认领状态,0-未认领,1-已认领
6 | TakeTime | datetime |  |  |  |  | √ |  | 认领时间
7 | FansId | varchar | 50 |  |  |  |  |  | 粉丝ID,主要为了微信扫码使用
8 | VrCode | varchar | 50 |  |  |  |  |  | 记录唯一码,扫码的时候只能用一次
9 | EquId | int |  |  |  |  |  |  | 设备ID
10 | Ecode | varchar | 50 |  |  |  |  |  | 机器码
11 | FamilyId | int |  |  |  |  |  |  | 家庭成员ID,为0则为自己
12 | UserId | int |  |  |  |  |  |  | 所属用户ID
13 | Createtime | datetime |  |  |  |  |  |  | 测量时间
14 | Type | int |  |  |  |  |  | 1 | 类型,1-单阻抗,2-八电极
15 | PublicId | varchar | 50 |  |  |  |  | '' | 公众号appid
16 | OrderId | uniqueidentifier | 36 |  |  |  |  |  | 订单ID
17 | BusinessId | int |  |  |  |  |  | 0 | 商户ID


dbo.YB_ResultAdd

dbo.YB_ResultAdd 手动添加的记录 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | ResultId | int |  |  |  |  |  |  | 关联的记录ID
3 | Height | decimal | 10 | 2 |  |  |  |  | 身高值,CM
4 | Weight | decimal | 18 | 2 |  |  |  |  | 体重值,KG
5 | UserId | int |  |  |  |  |  |  | 用户ID
6 | FamilyId | int |  |  |  |  |  |  | 家庭成员ID
7 | ResultTime | datetime |  |  |  |  |  |  | 测量时间
8 | CreateTime | datetime |  |  |  |  |  |  | 添加时间


dbo.YB_ResultExt

dbo.YB_ResultExt 测量记录扩展表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  | 测量记录ID
2 | ResultId | int |  |  |  |  |  |  | 称重记录ID
3 | Weight | decimal | 18 | 2 |  |  |  |  | 体重,单位为KG
4 | Height | decimal | 10 | 2 |  |  |  |  | 身高,厘米
5 | Imp | decimal | 18 | 2 |  |  |  |  | 阻抗值
6 | EquId | int |  |  |  |  |  |  | 设备ID
7 | Ecode | varchar | 50 |  |  |  |  |  | 设备机器码
8 | FacEcode | varchar | 50 |  |  |  |  |  | 设备序列号
9 | SourceType | int |  |  |  |  |  |  | 来源,1-蓝牙传输,2-手动记录,3-扫码记录
10 | PublicId | varchar | 50 |  |  |  |  |  | 所属的公众号/小程序
11 | FansId | varchar | 50 |  |  |  |  |  | 扫码时使用的用户唯一标识
12 | UserId | int |  |  |  |  |  |  | 用户ID
13 | BusinessId | int |  |  |  |  |  |  | 客户ID
14 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
15 | Type | int |  |  |  |  |  | 1 | 类型,1-单阻抗,2-八电极
16 | OrderId | uniqueidentifier | 36 |  |  |  |  |  | 订单ID


dbo.YB_Role

dbo.YB_Role 角色表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Name | nvarchar | 50 |  |  |  |  |  | 角色名称
3 | Code | varchar | 50 |  |  |  |  |  | 角色编号
4 | Remark | nvarchar | 200 |  |  |  |  |  | 角色备注
5 | Status | int |  |  |  |  |  |  | 状态,0-禁用,1-启用
6 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_RoleMenu

dbo.YB_RoleMenu 角色菜单表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | RoleId | int |  |  |  |  |  |  | 角色ID
3 | MenuId | int |  |  |  |  |  |  | 菜单ID
4 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_ScanResult

dbo.YB_ScanResult 扫码关注公众号记录 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Type | int |  |  |  |  |  |  | 类型,1-单阻抗,2-八电极
3 | Subscribe | int |  |  |  |  |  |  | 关注状态,0-未关注,1-已关注,2-重复关注
4 | TakeTime | datetime |  |  |  |  | √ |  | 计费时间
5 | FansId | varchar | 50 |  |  |  |  |  | 粉丝ID
6 | PublicId | varchar | 50 |  |  |  |  |  | 公众号appid
7 | OrderId | uniqueidentifier | 36 |  |  |  |  |  | 订单ID
8 | BusinessId | int |  |  |  |  |  |  | 客户ID
9 | EquId | int |  |  |  |  |  |  | 设备ID
10 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_SecInfo

dbo.YB_SecInfo 科普资讯 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Type | int |  |  |  |  |  |  | 类型,1-文本,2-链接,3-跳转小程序
3 | Title | nvarchar | 100 |  |  |  |  |  | 标题
4 | TagId | int |  |  |  |  |  |  | 所属分组ID
5 | HeadImg | varchar | 100 |  |  |  |  |  | 标题
6 | ClickCount | int |  |  |  |  |  |  | 点击次数
7 | Status | int |  |  |  |  |  |  | 状态,0-未开启,1-正常运行,2-已关闭
8 | StatusRemark | nvarchar | 50 |  |  |  |  |  | 状态备注
9 | BusienssId | int |  |  |  |  |  |  | 商户ID
10 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
11 | AppId | varchar | 50 |  |  |  | √ | 'wx920fdb58338cc50a' | 小程序appid


dbo.YB_SecInfoContent

dbo.YB_SecInfoContent 科普资讯内容 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  |  | √ |  |  |
2 | InfoId | int |  |  |  |  |  |  |
3 | Content | text | 2147483647 |  |  |  |  |  | 内容


dbo.YB_SecInfoType

dbo.YB_SecInfoType 科普资讯类型 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Name | nvarchar | 50 |  |  |  |  |  | 分组名称
3 | Remark | nvarchar | 100 |  |  |  |  |  | 备注
4 | Status | int |  |  |  |  |  |  | 状态,0-禁用,1-启用
5 | SortCode | int |  |  |  |  |  |  | 排序,数字越小越靠前
6 | BusienssId | int |  |  |  |  |  |  | 商户ID
7 | CreateTime | datetime |  |  |  |  |  |  | 添加时间


dbo.YB_TestEnm

dbo.YB_TestEnm 测试 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Sex | int |  |  |  |  |  |  |


dbo.YB_UserChildBody

dbo.YB_UserChildBody 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | Type | int |  |  |  |  |  |  | 体质类型
3 | Result | int |  |  |  |  |  |  | 判定结果,1-是,2-倾向是,3-否
4 | Score | int |  |  |  |  |  |  | 得分
5 | UserId | int |  |  |  |  |  |  | 用户ID
6 | FamilyId | int |  |  |  |  |  |  | 家庭成语ID
7 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_UserDev

dbo.YB_UserDev 用户使用过的设备列表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | DevId | int |  |  |  |  |  |  | 设备ID
3 | UserId | int |  |  |  |  |  |  | 用户ID
4 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_UserEqu

dbo.YB_UserEqu 用户使用过的设备类型 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | DevType | int |  |  |  |  |  |  | 设备类型
3 | UserId | int |  |  |  |  |  |  | 用户ID
4 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_UserLastData

dbo.YB_UserLastData 用户最近的测量信息 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | UserId | int |  |  | √ |  |  |  | 用户ID
2 | LastResultId | uniqueidentifier | 36 |  |  |  |  |  | 最近的记录ID
3 | LastResultTime | datetime |  |  |  |  |  |  | 最近的记录时间


dbo.YB_UserRealData

dbo.YB_UserRealData 用户实时数据 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | UserId | int |  |  |  |  |  |  | 用户ID
3 | TopStep | bigint |  |  |  |  |  |  | 最高运动步数
4 | TopStepTime | bigint |  |  |  |  |  |  | 最大运动步数时间,时间戳格式


dbo.YB_UserSubscribeMessage

dbo.YB_UserSubscribeMessage 用户订阅消息 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | IsAlWays | bit | 1 |  |  |  |  |  | 是否总是订阅,true-是,false-否
3 | Type | int |  |  |  |  |  |  | 订阅的消息类型,1-周提醒,2-月提醒,3-半年提醒,4-一年提醒
4 | OpenId | varchar | 255 |  |  |  |  |  | 用户openid
5 | AppId | varchar | 255 |  |  |  |  |  | 小程序appid
6 | TplId | varchar | 255 |  |  |  |  |  | 模板ID
7 | UserId | int |  |  |  |  |  |  | 用户ID
8 | CreateTime | date | 10 | 0 |  |  |  |  | 创建时间


dbo.YB_UserWX

dbo.YB_UserWX 注册用户管理的微信数据 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | UserId | int |  |  |  |  |  |  | 用户ID
3 | openid | varchar | 50 |  |  |  |  |  | 用户openid
4 | unionid | varchar | 50 |  |  |  |  |  | 用户unionid
5 | createtime | datetime |  |  |  |  |  |  | 创建时间
6 | IsOutLogin | int |  |  |  |  | √ | '1' | 是否退出登录，1-否,0-是


dbo.YB_WeightStand

dbo.YB_WeightStand 体重标准 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  |  | √ |  |  |
2 | Month | int |  |  |  |  |  |  | 月龄
3 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女
4 | f3sd | decimal | 5 | 1 |  |  |  |  | -3SD
5 | f2sd | decimal | 5 | 1 |  |  |  |  | -2SD
6 | f1sd | decimal | 5 | 1 |  |  |  |  | -1SD
7 | median | decimal | 5 | 1 |  |  |  |  | 中位数
8 | z1sd | decimal | 5 | 1 |  |  |  |  | +1SD
9 | z2sd | decimal | 5 | 1 |  |  |  |  | +2SD
10 | z3sd | decimal | 5 | 1 |  |  |  |  | +3SD


dbo.YB_WifiBind

dbo.YB_WifiBind wifi绑定记录 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | FansId | uniqueidentifier | 36 |  |  |  |  |  | 粉丝ID
3 | FansUnionId | varchar | 50 |  |  |  |  |  | 用户唯一标识
4 | DevId | int |  |  |  |  |  |  | 设备ID
5 | DevCode | varchar | 50 |  |  |  |  |  | 设备机器码
6 | PublicId | varchar | 50 |  |  |  |  |  | 公众号appid
7 | OpenId | varchar | 50 |  |  |  |  |  | 用户Openid
8 | Subscribe | int |  |  |  |  |  |  | 公众号的关注情况,0-取关,1-已关
9 | BindStatus | int |  |  |  |  |  |  | 绑定状态,0-未绑定,1-已绑定
10 | CreateTime | datetime |  |  |  |  |  |  | 创建时间
11 | BindTime | datetime |  |  |  |  | √ |  | 绑定时间
12 | UnBindTime | datetime |  |  |  |  | √ |  | 解绑时间


dbo.YB_WXCustomService

dbo.YB_WXCustomService 微信客服 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | AppId | varchar | 50 |  |  |  |  |  | 小程序appid
3 | QyAppId | varchar | 50 |  |  |  |  |  | 企业微信appid
4 | Url | varchar | 100 |  |  |  |  |  | 客服链接
5 | CreateTime | datetime |  |  |  |  |  |  |


dbo.YB_WXFans

dbo.YB_WXFans 粉丝数据表 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | NickName | nvarchar | 100 |  |  |  |  |  | 昵称
3 | HeadImgUrl | varchar | 200 |  |  |  |  |  | 头像地址
4 | Sex | int |  |  |  |  |  |  | 性别,1-男,2-女,0-未知
5 | City | nvarchar | 100 |  |  |  |  |  | 城市
6 | Country | nvarchar | 100 |  |  |  |  |  | 国家
7 | Province | nvarchar | 100 |  |  |  |  |  | 省份
8 | Language | varchar | 50 |  |  |  |  |  | 语言
9 | FromType | int |  |  |  |  |  |  | 来源类型,1-扫码网页授权,2-小程序
10 | OldOpenId | varchar | 50 |  |  |  |  |  | 针对网页授权号的openid
11 | FansId | varchar | 50 |  |  |  |  |  | 针对网页授权号的unionid
12 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_WXFansExt

dbo.YB_WXFansExt 用户关注公众号相关 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | ResultId | uniqueidentifier | 36 |  |  |  |  |  | 粉丝ID
3 | AppId | varchar | 50 |  |  |  |  |  | 公众号appid
4 | OpenId | varchar | 50 |  |  |  |  |  | 用户openid
5 | Subscribe | int |  |  |  |  |  |  | 关注状态,-1-状态未知,0-取关,1-已关注
6 | SubscribeTime | datetime |  |  |  |  |  |  | 关注时间
7 | UnSubscribeTime | datetime |  |  |  |  | √ |  | 取关时间


dbo.YB_WXMessage

dbo.YB_WXMessage 微信公众号关键字 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | uniqueidentifier | 36 |  | √ |  |  |  |
2 | EnCode | varchar | 50 |  |  |  |  |  | 关键字
3 | PublicId | varchar | 50 |  |  |  |  |  | 公众号appid
4 | ResultId | varchar | 50 |  |  |  |  |  | 记录ID
5 | Type | int |  |  |  |  |  |  | 类型,1-带测量参数二维码,2-固定二维码
6 | CreateTime | datetime |  |  |  |  |  |  | 创建时间


dbo.YB_WXRun

dbo.YB_WXRun 微信步数 返回目录
序号 | 列名 | 数据类型 | 长度 | 小数位数 | 主键 | 自增 | 允许空 | 默认值 | 列说明
1 | Id | int |  |  | √ | √ |  |  |
2 | Step | bigint |  |  |  |  |  |  | 步数
3 | CreateTime | date | 10 | 0 |  |  |  |  | 时间
4 | TimeStamp | bigint |  |  |  |  |  |  | 时间戳形式
5 | UserId | int |  |  |  |  |  |  | 用户ID


proc_body_binduser

-- =============================================
-- Author:		liuzl
-- Create date: 2021-05-20
-- Description:	八电极wifi秤用户绑定
-- =============================================
CREATE proc [dbo].[proc_body_binduser]
  @wxfansid UNIQUEIDENTIFIER=NULL,--主ID
  @subscribe INT=-1,---1-未知状态,0-取关,2-已关注
  @fansid VARCHAR(50)='',--用户唯一标识
  @fansuserid UNIQUEIDENTIFIER=NULL,--在yb_wxfans表中的id
  @oldopenid VARCHAR(50)='',--针对网页授权号的openid
  @equid INT=0,--设备ID,
  @ecode VARCHAR(50)='',--设备机器码
  @facecode VARCHAR(50)='',--设备序列号
  @orderid UNIQUEIDENTIFIER=NULL,--订单id
  @businessid INT=0,--设备所属服务商
  @publicid VARCHAR(50)='',--公众号原始id
  @headimgurl VARCHAR(200)='',--用户头像
  @nickname NVARCHAR(100)='',--用户昵称
  @sex INT=0,--用户性别
  @city NVARCHAR(100)='',--城市
  @province NVARCHAR(100)='',--省份
  @country NVARCHAR(100)='',--国家
  @language VARCHAR(50)='',--语言
  @ordertype INT = 1 --订单类型,1-公众号,2-链接
  as
  begin
  SET   XACT_ABORT   ON
  --第一次扫码时的操作
  IF @subscribe=-1
  BEGIN
      --保存粉丝数据,-1-未知状态,0-取关,1-关注,2-关注并绑定
        IF EXISTS(SELECT 1 FROM dbo.YB_WXFans WHERE FansId=@fansid)
        BEGIN
            SELECT @wxfansid=Id FROM dbo.YB_WXFans WHERE FansId=@fansid

            UPDATE dbo.YB_WXFans SET HeadImgUrl=@headimgurl,NickName=@nickname,sex=@sex,
            City=@city,Country=@country,Province=@province,[Language]=@language
            WHERE id=@wxfansid
        END
        ELSE
        BEGIN
            INSERT INTO dbo.YB_WXFans
            (
                id,
                NickName,
                HeadImgUrl,
                Sex,
                City,
                Country,
                Province,
                [Language],
                FromType,
                OldOpenId,
                FansId,
                CreateTime
            )
            VALUES(@wxfansid,@nickname,@headimgurl,@sex,@city,@country,@province,@language,1,@oldopenid,@fansid,GETDATE())
        END
        --记录关注情况
        IF NOT EXISTS(SELECT 1 FROM dbo.YB_WXFansExt WHERE AppId=@publicid AND ResultId=@wxfansid)
        BEGIN
            INSERT into dbo.YB_WXFansExt
            (
                ResultId,
                AppId,
                OpenId,
                Subscribe,
                SubscribeTime
            )
            VALUES
            ( @wxfansid, @publicid, '',  -1, GETDATE())
        END

        SELECT @wxfansid
  END
  --取关
  ELSE IF @subscribe=0
  BEGIN
    --更新取关记录
    IF EXISTS(SELECT 1 FROM dbo.YB_WXFansExt WHERE AppId=@publicid AND OpenId=@oldopenid)
    BEGIN
        UPDATE dbo.YB_WXFansExt SET Subscribe=0,UnSubscribeTime=GETDATE() WHERE AppId=@publicid AND OpenId=@oldopenid

        --更新绑定记录
        IF EXISTS(SELECT 1 FROM dbo.YB_WifiBind WHERE OpenId=@oldopenid AND PublicId=@publicid)
            BEGIN
                UPDATE dbo.YB_WifiBind SET Subscribe=0 WHERE OpenId=@oldopenid AND PublicId=@publicid
            END
    END
  END
  --关注公众号时的操作
  ELSE IF @subscribe=1
  BEGIN
    --增加关注记录
    IF EXISTS(SELECT 1 FROM dbo.YB_WXFansExt WHERE AppId=@publicid AND OpenId=@oldopenid)
    BEGIN
        UPDATE dbo.YB_WXFansExt SET Subscribe=1,SubscribeTime=GETDATE() WHERE AppId=@publicid AND OpenId=@oldopenid
        IF EXISTS(SELECT 1 FROM dbo.YB_WifiBind WHERE OpenId=@oldopenid AND PublicId=@publicid)
            BEGIN
                UPDATE dbo.YB_WifiBind SET Subscribe=1 WHERE OpenId=@oldopenid AND PublicId=@publicid
            END
    END
  END
  --关注并绑定
  ELSE IF @subscribe=2
  BEGIN
      --增加关注记录
        IF EXISTS(SELECT 1 FROM dbo.YB_WXFansExt WHERE AppId=@publicid AND OpenId=@oldopenid)
        BEGIN
            UPDATE dbo.YB_WXFansExt SET Subscribe=1,SubscribeTime=GETDATE() WHERE AppId=@publicid AND OpenId=@oldopenid
        END
        ELSE
        BEGIN
            INSERT INTO dbo.YB_WXFansExt
            (
                ResultId,
                AppId,
                OpenId,
                Subscribe,
                SubscribeTime
            )
            VALUES(@fansuserid,@publicid,@oldopenid,1,GETDATE())
        END
        -- 记录绑定情况
    IF EXISTS(SELECT 1 FROM dbo.YB_WifiBind WHERE FansId=@fansuserid AND PublicId=@publicid AND DevId=@equid)
    BEGIN
        UPDATE dbo.YB_WifiBind SET Subscribe=1,BindStatus=1,BindTime=GETDATE() WHERE FansId=@fansid AND PublicId=@publicid AND DevId=@equid
    END
    ELSE
    BEGIN
        INSERT INTO dbo.YB_WifiBind
        (
            FansId,
            FansUnionId,
            DevId,
            DevCode,
            PublicId,
            OpenId,
            Subscribe,
            BindStatus,
            CreateTime,
            BindTime,
            UnBindTime
        )
        VALUES(@fansuserid,@fansid,@equid,@ecode,@publicid,@oldopenid,1,1,GETDATE(),GETDATE(),NULL)
    END
  END
end


proc_ClearDayData

--=============================================
-- Author:		liuzl
-- Create date: 2021-03-15
-- Description:	清理当日数据
-- =============================================
CREATE PROCEDURE [dbo].[proc_ClearDayData]
AS
BEGIN
    SET NOCOUNT ON;
    DECLARE @time DATETIME
    SET @time = DATEADD(DAY,-7,GETDATE())
    SET @time = CONVERT(DATETIME,CONVERT(VARCHAR(10),@time,120))

    --清理总计统计表
    UPDATE dbo.YB_Combined SET TodayRegCnt=0,TodayResultCnt=0,TodayDevCnt=0,TodayIncome=0 WHERE id=1

    --清理扫码订单
    UPDATE dbo.YB_Order SET DayCount=0,DayRealCount=0

    --清理客户统计
    UPDATE dbo.YB_BusinessRealData SET TodayResultCnt=0,TodayIncome=0,TodayDevCount=0

    --清理设备统计数据
    UPDATE dbo.YB_EquRealData SET TodayResultCnt=0,TodayInCome=0

    --清理家庭成员数据
    UPDATE dbo.YB_FamilyData SET TodayCount=0

    --清理家庭成员数据
    UPDATE dbo.YB_FamilyRealData SET TodayCount=0
    --yb_result只保留一周的数据
    --DELETE FROM dbo.YB_Result WHERE Createtime<@time

END


proc_fanssubcribestatus

-- =============================================
-- Author:		liuzl
-- Create date: 20210706
-- Description:	粉丝关注状态变化
-- =============================================
CREATE PROCEDURE  proc_fanssubcribestatus
    @appid VARCHAR(50),--公众号appid
    @openid VARCHAR(50),--openid
    @subscribe INT --1-关注,0-取关
AS
BEGIN
    -- SET NOCOUNT ON added to prevent extra result sets from
    -- interfering with SELECT statements.
    SET NOCOUNT ON;
    --关注
    IF @subscribe=1
    BEGIN
        --更新粉丝关注状态
        UPDATE dbo.YB_WXFansExt SET Subscribe=@subscribe,SubscribeTime=GETDATE() WHERE AppId=@appid AND OpenId=OpenId

        --更新八电极绑定关注状态
        UPDATE dbo.YB_WifiBind SET Subscribe=@subscribe WHERE PublicId=@appid AND OpenId=@openid
    END
    ELSE
    --取关
    BEGIN
        --更新粉丝关注状态
        UPDATE dbo.YB_WXFansExt SET Subscribe=@subscribe,UnSubscribeTime=GETDATE() WHERE AppId=@appid AND OpenId=OpenId

        --更新八电极绑定关注状态
        UPDATE dbo.YB_WifiBind SET Subscribe=@subscribe WHERE PublicId=@appid AND OpenId=@openid
    END

END


proc_getmeasureitem_page

-- =============================================
-- Author:		liuzl
-- Create date: 2017-12-07
-- Description:	根据familyid获取用户测量数据结果,  按次数或者按天获取历史记录,支持分页
-- test:exec proc_getmeasureitem_page 0,1,10,18807,36,1,'2022-10-01','2022-12-12'
-- =============================================
CREATE PROCEDURE [dbo].[proc_getmeasureitem_page]
    @nopage INT=1,--0-不分页，1-分页
    @pagesize INT=1,	--页码
    @pagenum INT=10, --每页显示数量
    @familyid bigint=0,--家庭成员ID
    @type INT=1, --1- 单电阻,2-八电极
    @stype INT =0,--0-按次、按天,1-按次,2-按天
    @starttime DATETIME =NULL,--开始时间
    @endtime DATETIME=NULL --结束时间
AS
BEGIN

 declare @myresult table
(
    resultid varchar(50) null,
    [fat_r] [nvarchar](50) NULL,
    [muscle] [nvarchar](50) NULL,
    [water] [nvarchar](50) NULL,
    [bone] [nvarchar](50) NULL,
    [kcal] [nvarchar](50) NULL,
    [fat_w] [nvarchar](50) NULL,
    [visceral] [nvarchar](50) NULL,
    [protein] [nvarchar](50) NULL,
    [bodyage] INT NULL,
    [bmi] [nvarchar](50) NULL,
    [createtime] [datetime] NULL,
    [sfr] DECIMAL(18,2) NULL,
    muscleval DECIMAL(18,2) NULL,
    proteinval DECIMAL(18,2) NULL,
    lbm DECIMAL(18,2) NULL,
    body NVARCHAR(50) NULL,
    fat NVARCHAR(50) NULL,
    [weight] decimal(18,2),
    height DECIMAL(18,2)
)
DECLARE @cont VARCHAR(50) --设备包含的共享设备类型列表
IF 1=1
BEGIN
    SELECT @cont=Content FROM dbo.YB_DeviceType WHERE Code=@type
     --如果是HD01,则1,3,6均属于同一类，统一加载
     --如果是L01,则4,5均属于同一类,统一加载
         INSERT into @myresult
        select a.id, a.fat_r,a.muscle,a.water,a.bone,a.kcal,a.fat_w,a.visceral,a.protein,a.bodyage,a.bmi,a.createtime,a.sfr,a.muscleval,a.proteinval,a.lbm,a.body,a.fatlevel,a.[Weight],a.height
        FROM dbo.YB_nUserResult b
        LEFT JOIN dbo.YB_nMeasureResult a
        ON a.id=b.id
        WHERE b.FamilyId=@familyid AND EXISTS(SELECT 1 FROM dbo.F_SQLSERVER_SPLIT(@CONT,',') WHERE short_str=b.DevType) AND a.createtime>=@starttime AND a.createtime<@endtime AND b.[Status]=1

     if @pagesize <=0
        set @pagesize=1

    IF @stype=0 --按次按天
    BEGIN
         select top (select @pagenum) a.resultid, a.fat_r,a.muscle,a.water,a.bone,a.kcal,a.fat_w,a.visceral,a.protein,a.bodyage,a.bmi,a.sfr,a.muscleval,a.proteinval,a.lbm,a.body,a.fat,a.[weight],a.height,
         CONVERT(VARCHAR(50),a.createtime) [timestamp] into #temp2 from
         (select row_number() over(order by createTime desc) as rownumber,* from  @myresult) a
         WHERE
           createTime in (select max(createTime) from @myresult group by CONVERT(char(10), createtime, 121))
           AND rownumber>(@pagesize-1)*@pagenum

        select *from #temp2    order by timestamp desc

          select top (select @pagenum) resultid, isnull(fat_r,0) fat_r,isnull(muscle,0) muscle,isnull(water,0) water,isnull(bone,0) bone,isnull(kcal,0) kcal,isnull(fat_w,0) fat_w,
          ISNULL(visceral,0) visceral,isnull(protein,0) protein,isnull(bodyage,0) bodyage,bmi,sfr,muscleval,proteinval,lbm,body,fat,[weight],height,
          CONVERT(VARCHAR(50),createtime) [timestamp] from
         (select row_number() over(order by createTime desc) as rownumber,* from  @myresult) temp_row
         where rownumber>(@pagesize-1)*@pagenum
         ORDER BY createtime desc
    END
    ELSE IF @stype=1 --按次
    BEGIN
        IF @nopage =1
        BEGIN
                SELECT top (select @pagenum) resultid, isnull(fat_r,0) fat_r,isnull(muscle,0) muscle,isnull(water,0) water,isnull(bone,0) bone,isnull(kcal,0) kcal,isnull(fat_w,0) fat_w,
              ISNULL(visceral,0) visceral,isnull(protein,0) protein,isnull(bodyage,0) bodyage,bmi,sfr,muscleval,proteinval,lbm,body,fat,[weight],height,
              CONVERT(VARCHAR(50),createtime) [timestamp] from
             (select row_number() over(order by createTime desc) as rownumber,* from  @myresult) temp_row
             where rownumber>(@pagesize-1)*@pagenum
             ORDER BY createtime desc
        END
        ELSE
        BEGIN
                SELECT resultid, isnull(fat_r,0) fat_r,isnull(muscle,0) muscle,isnull(water,0) water,isnull(bone,0) bone,isnull(kcal,0) kcal,isnull(fat_w,0) fat_w,
              ISNULL(visceral,0) visceral,isnull(protein,0) protein,isnull(bodyage,0) bodyage,bmi,sfr,muscleval,proteinval,lbm,body,fat,[weight],height,
              CONVERT(VARCHAR(50),createtime) [timestamp] from
             @myresult
             ORDER BY createtime desc
        END
    END
    ELSE
    BEGIN IF @stype=2 --按天
         select top (select @pagenum) a.resultid, a.fat_r,a.muscle,a.water,a.bone,a.kcal,a.fat_w,a.visceral,a.protein,a.bodyage,a.bmi,a.sfr,a.muscleval,a.proteinval,a.lbm,a.body,a.fat,a.[weight],a.height,
         CONVERT(VARCHAR(50),a.createtime) [timestamp]  from
         (select row_number() over(order by createTime desc) as rownumber,* from  @myresult) a
         WHERE
           createTime in (select max(createTime) from @myresult group by CONVERT(char(10), createtime, 121))
           AND rownumber>(@pagesize-1)*@pagenum
           ORDER BY a.createtime desc
    END
END
ELSE
BEGIN
     select bmi,a.fat_r,[a].[Weight],a.Height,a.muscle,a.createtime from
     (select row_number() over(order by createTime desc) as rownumber,* from  dbo.YB_nMeasureResult) a
     WHERE
        a.createtime>=@starttime AND a.createtime<@endtime AND a.DevType=@type AND EXISTS(SELECT 1 FROM dbo.YB_nUserResult WHERE a.id=id AND [status]=1 AND FamilyId=@familyid)
       AND createTime in
       (select max(createTime) from YB_nMeasureResult b
       WHERE createtime>=@starttime AND createtime<@endtime AND DevType=@type AND EXISTS(SELECT 1 FROM dbo.YB_nUserResult WHERE b.id=id AND [status]=1 AND FamilyId=@familyid)
       GROUP by CONVERT(char(10), createtime, 121))

END

END


PROC_GetOrder

--=============================================
-- Author:		liuzl
-- Create date: 2021-03-15
-- Description:	获取使用的订单
-- test: exec PROC_GetOrder 29107,4,'oqmUFwsD6v-reC8oBORWFsoIGSYU',2,0,1
-- =============================================
CREATE PROCEDURE [dbo].[PROC_GetOrder]
    @equid INT, --设备id
    @businessid INT=0,--设备服务商id
    @fansid VARCHAR(50), --用户唯一标识
    @ordertype INT = 2,--1-设备管理,2-用户测量,3-用户绑定
    @isdefault INT=0, --1-公众号,2-链接,3-小程序,0-全部
    @scantype INT=1 --1-固定贴纸,2-带测量信息的二维码
AS
BEGIN

DECLARE @table TABLE(
    id UNIQUEIDENTIFIER,
    [Name] NVARCHAR(50),
    [Type] INT,
    [Url] VARCHAR(200),
    [Page] varchar(100),
     RealCount INT,
    [ShowCount] INT,
    TotalCount INT,
    DayCount INT,
    DayRealCount INT,
    DayLimit INT,
    StartTime DATETIME,
    EndTime DATETIME,
    [Status] INT,
    StatusRemark nvarchar(100),
    [Priority] INT,
    BusinessId INT,
    CreateTime DATETIME,
    ordertype INT
)

    SET NOCOUNT ON;
    --如果是固定贴纸,并且是八电极则取用户绑定公众号订单
    IF @scantype=1 AND @isdefault !=3 AND EXISTS(SELECT 1 FROM dbo.YB_Device WHERE id=@equid AND [type]=2)
    BEGIN
        SET @isdefault=1
        SET @ordertype=3
    END
    --非取全部
    IF @isdefault != 0
    BEGIN
        INSERT INTO @table
        (id,Name,Type,Url,Page,RealCount,ShowCount,TotalCount,DayCount,DayRealCount,DayLimit,StartTime,EndTime,
        Status,StatusRemark,Priority,BusinessId,CreateTime,ordertype)
        SELECT TOP 1 *  FROM dbo.YB_Order a
        WHERE [Status]=1
        AND (StartTime<=GETDATE() OR a.StartTime IS NULL)
        AND (DATEADD(day,1,EndTime)>=GETDATE() OR a.EndTime IS NULL)
        AND (TotalCount=0 OR RealCount=GETDATE() OR a.EndTime IS NULL)
        AND (TotalCount=0 OR RealCount


PROC_GetScanOrder

--=============================================
-- Author:		liuzl
-- Create date: 2021-03-15
-- Description:	获取扫码使用的订单
-- test: exec proc_getscanorder 5,1,2,'oqmUFwsD6v-reC8oBORWFsoIGSYU',0,0
-- =============================================
CREATE PROCEDURE [dbo].[PROC_GetScanOrder]
    @equid INT, --设备id
    @businessid INT=0,--设备服务商id
    @equtype INT=1,--设备类型，1-HD01BT,2-H018
    @fansid VARCHAR(50), --用户唯一标识
    @isbinduser INT=0,--是否为八电极绑定用户,0-否,1-是
    @ordertype INT = 2,--1-设备管理,2-用户测量
    @isdefault INT=0 --1-获取公众号,2-获取小程序,0-全部
AS
BEGIN

DECLARE @table TABLE(
    id UNIQUEIDENTIFIER,
    [Name] NVARCHAR(50),
    [Type] INT,
    [Url] VARCHAR(200),
    [Page] varchar(100),
     RealCount INT,
    [ShowCount] INT,
    TotalCount INT,
    DayCount INT,
    DayRealCount INT,
    DayLimit INT,
    StartTime DATETIME,
    EndTime DATETIME,
    [Status] INT,
    StatusRemark nvarchar(100),
    [Priority] INT,
    BusinessId INT,
    CreateTime DATETIME,
    ordertype INT
)

    SET NOCOUNT ON;
    --如果为非绑定取单则正常进行查询,否则直接默认订单
    IF @isbinduser=0
    BEGIN
    INSERT INTO @table
    (
        id,
        Name,
        Type,
        Url,
        Page,
        RealCount,
        ShowCount,
        TotalCount,
        DayCount,
        DayRealCount,
        DayLimit,
        StartTime,
        EndTime,
        Status,
        StatusRemark,
        Priority,
        BusinessId,
        CreateTime,
        ordertype
    )
    SELECT TOP 1 *  FROM dbo.YB_Order a
    WHERE [Status]=1
    AND (StartTime<=GETDATE() OR a.StartTime IS NULL)
    AND (DATEADD(day,1,EndTime)>=GETDATE() OR a.EndTime IS NULL)
    AND (TotalCount=0 OR RealCount


proc_insertresult

-- =============================================
-- Author:		liuzl
-- Create date: 2021-01-20
-- Description:	 增加测量记录
-- Test:  exec proc_insertresult 2,18,216,175,68,560,'88:4A:18:71:01:9B','', 1,1,31.0,15.0,52.1,2.7,1382.8,21.08,4,12.6,19,22.2,97.3,28.9,10.2,8.57,46.92,'隐形肥胖','标准'
-- =============================================
CREATE PROCEDURE [dbo].[proc_insertresult]
    @isfirst INT=0,--是否为通过H5跳转的第一次打开,0-否,1-是
    @sex INT=0,--性别,1-男,2-女,0-未知
    @age INT,--年龄
    @month INT,--相差的月份
    @height DECIMAL(10,2),--身高,厘米
    @weight DECIMAL(18,2),--体重,KG
    @imp  DECIMAL(18,2),--阻抗
    @ecode VARCHAR(50),--设备码
    @fansid VARCHAR(50)='',--用户唯一标识
    @familyid INT,--领取的家庭成员ID
    @userid INT, --用户ID
    @fat_r DECIMAL(18,2)=0,--脂肪率
    @muscle DECIMAL(18,2)=0,--肌肉率
    @water DECIMAL(18,2)=0,--水份
    @bone DECIMAL(18,2)=0,--骨重
    @kcal DECIMAL(18,2)=0,--基础代谢
    @fat_w DECIMAL(18,2)=0,--脂肪重量
    @visceral DECIMAL(18,2)=0,--内脂
    @protein DECIMAL(18,2)=0,--蛋白质
    @bodyage DECIMAL(18,2)=0,--体龄
    @bmi DECIMAL(18,2)=0,--bmi
    @cmi DECIMAL(18,2)=0,--分数
    @sfr DECIMAL(18,2)=0,--皮下脂肪
    @muscleval DECIMAL(18,2)=0,--肌肉量
    @proteinval DECIMAL(18,2)=0,--蛋白量
    @lbm DECIMAL(18,2)=0,--去脂体重
    @body VARCHAR(50)='',--体型
    @fatlevel VARCHAR(50)='',--肥胖等级
    @bodymuscle DECIMAL(18,2)=0,--躯干肌肉率
    @leftfootmuscle DECIMAL(18,2)=0,--左脚肌肉率
    @rightfootmuscle DECIMAL(18,2)=0,--右脚肌肉率
    @lefthandmuscle DECIMAL(18,2)=0,--左手肌肉率
    @righthandmuscle DECIMAL(18,2)=0,--右手肌肉率
    @bodyfat DECIMAL(18,2)=0,--躯干脂肪率
    @leftfootfat DECIMAL(18,2)=0,--左脚脂肪率
    @rightfootfat DECIMAL(18,2)=0,--右脚脂肪率
    @lefthandfat DECIMAL(18,2)=0,--左手脂肪率
    @righthandfat DECIMAL(18,2)=0,--右手脂肪率
    @bodymuscleval DECIMAL(18,2)=0,--躯干肌肉量
    @leftfootmuscleval DECIMAL(18,2)=0,--左脚肌肉量
    @rightfootmuscleval DECIMAL(18,2)=0,--右脚肌肉量
    @lefthandmuscleval DECIMAL(18,2)=0,--左手肌肉量
    @righthandmuscleval DECIMAL(18,2)=0,--右手肌肉量
    @bodyfatval DECIMAL(18,2)=0,--躯干脂肪量
    @leftfootfatval DECIMAL(18,2)=0,--左脚脂肪量
    @rightfootfatval DECIMAL(18,2)=0,--右脚脂肪量
    @lefthandfatval DECIMAL(18,2)=0,--左手脂肪量
    @righthandfatval DECIMAL(18,2)=0,--右手脂肪量
    @sfrval DECIMAL(18,2)=0,--皮下脂肪量,kg
    @idealweight DECIMAL(18,2)=0,--理想体重
    @skeletalmuscle DECIMAL(18,2)=0,--骨骼肌量,kg
    @leveljson VARCHAR(500)='',--八电极等级标准
    @sourcetype INT=1,-- 1-蓝牙传输,2-手动记录
    @createtime DATETIME=NULL,--测量时间,手动记录使用
    @type INT=1,--1-单电阻,2-八电极
    @resultid INT=0 --最新的记录id,如果传递此值,则进行更新操作
AS
BEGIN
DECLARE @equid INT,@facecode VARCHAR(50),@Businessid INT,@lasthearttime DATETIME,
@isdevactive INT=0 --设备活跃台数是否+1,0-否,1-是
        SET   XACT_ABORT   ON
        IF @resultid>0
        BEGIN
            --是否为第一次打开
            IF @isfirst=1
            BEGIN
                --更新yb_result
                UPDATE dbo.YB_Result SET UserId=@userid,FamilyId=@familyid WHERE id=@resultid
                UPDATE dbo.YB_Result SET TaskStatus=1,TakeTime=GETDATE() WHERE id=@resultid AND TaskStatus=0

                --更新yb_resultext
                UPDATE dbo.YB_ResultExt SET UserId=@userid WHERE ResultId=@resultid

                --更新计算结果值
                IF(@type=1)
                BEGIN
                    UPDATE dbo.YB_Measure SET Height=@height,Sex=@sex,Age=@age,fat_r=@fat_r,muscle=@muscle,water=@water,
                    bone=@bone,kcal=@kcal,fat_w=@fat_w,visceral=@visceral,protein=@protein,bodyage=@bodyage,bmi=@bmi,
                    cmi=@cmi,sfr=@sfr,muscleval=@muscleval,proteinval=@proteinval,lbm=@lbm,body=@body,fatlevel=@fatlevel,
                    [Month]=@month,FamilyId=@familyid
                    WHERE ResultId=@resultid
                END
                ELSE
                BEGIN
                    UPDATE dbo.YB_Measure SET Height=@height,Sex=@sex,Age=@age,fat_r=@fat_r,muscle=@muscle,water=@water,
                    bone=@bone,kcal=@kcal,fat_w=@fat_w,visceral=@visceral,protein=@protein,bodyage=@bodyage,bmi=@bmi,
                    cmi=@cmi,sfr=@sfr,muscleval=@muscleval,proteinval=@proteinval,lbm=@lbm,body=ISNULL(@body,''),fatlevel=@fatlevel,
                    [Month]=@month,FamilyId=@familyid
                    WHERE ResultId=@resultid

                    UPDATE dbo.YB_BodyMeasure SET BodyMuscle=@bodymuscle,LeftFootMuscle=@leftfootmuscle,RightFootMuscle=@rightfootmuscle,
                    LeftHandMuscle=@lefthandmuscle,RightHandMuscle=@righthandmuscle,BodyFat=@bodyfat,LeftFootFat=@leftfootfat,RightFootFat=@rightfootfat,
                    LeftHandFat=@lefthandfat,RightHandFat=@righthandfat,BodyMuscleVal=@bodymuscleval,LeftFootMuscleVal=@leftfootmuscleval,
                    RightFootMuscleVal=@rightfootmuscleval,LeftHandMuscleVal=@lefthandmuscleval,RightHandMuscleVal=@righthandmuscleval,
                    BodyFatVal=@bodyfatval,LeftFootFatVal=@leftfootfatval,RightFootFatVal=@rightfootfatval,LeftHandFatVal=@lefthandfatval,
                    RightHandFatVal=@righthandfatval,sfrval=@sfrval,idealweight=@idealweight,SkeletalMuscle=@skeletalmuscle,LevelJson=@leveljson
                    WHERE ResultId=@resultid
                END
            END
            ELSE
            BEGIN
                --更新计算结果值
                IF(@type=1)
                BEGIN
                    UPDATE dbo.YB_Measure SET Height=@height,Sex=@sex,Age=@age,fat_r=@fat_r,muscle=@muscle,water=@water,
                    bone=@bone,kcal=@kcal,fat_w=@fat_w,visceral=@visceral,protein=@protein,bodyage=@bodyage,bmi=@bmi,
                    cmi=@cmi,sfr=@sfr,muscleval=@muscleval,proteinval=@proteinval,lbm=@lbm,body=@body,fatlevel=@fatlevel,
                    [Month]=@month
                    WHERE ResultId=@resultid
                END
                ELSE
                BEGIN
                    --更新yb_result
                    UPDATE dbo.YB_Result SET UserId=@userid,FamilyId=@familyid WHERE id=@resultid

                    --更新yb_resultext
                    UPDATE dbo.YB_ResultExt SET UserId=@userid WHERE ResultId=@resultid
                    UPDATE dbo.YB_Measure SET Height=@height,Sex=@sex,Age=@age,fat_r=@fat_r,muscle=@muscle,water=@water,
                    bone=@bone,kcal=@kcal,fat_w=@fat_w,visceral=@visceral,protein=@protein,bodyage=@bodyage,bmi=@bmi,
                    cmi=@cmi,sfr=@sfr,muscleval=@muscleval,proteinval=@proteinval,lbm=@lbm,body=@body,fatlevel=@fatlevel,
                    [Month]=@month
                    WHERE ResultId=@resultid

                    UPDATE dbo.YB_BodyMeasure SET BodyMuscle=@bodymuscle,LeftFootMuscle=@leftfootmuscle,RightFootMuscle=@rightfootmuscle,
                    LeftHandMuscle=@lefthandmuscle,RightHandMuscle=@righthandmuscle,BodyFat=@bodyfat,LeftFootFat=@leftfootfat,RightFootFat=@rightfootfat,
                    LeftHandFat=@lefthandfat,RightHandFat=@righthandfat,BodyMuscleVal=@bodymuscleval,LeftFootMuscleVal=@leftfootmuscleval,
                    RightFootMuscleVal=@rightfootmuscleval,LeftHandMuscleVal=@lefthandmuscleval,RightHandMuscleVal=@righthandmuscleval,
                    BodyFatVal=@bodyfatval,LeftFootFatVal=@leftfootfatval,RightFootFatVal=@rightfootfatval,LeftHandFatVal=@lefthandfatval,
                    RightHandFatVal=@righthandfatval,sfrval=@sfrval,idealweight=@idealweight
                    WHERE ResultId=@resultid
                END
            END
        END
        ELSE
        BEGIN
            IF @sourcetype=1
            BEGIN
                SET @createtime=GETDATE()
            END

            --BEGIN TRAN tran_jifei
            SELECT TOP 1 @equid=Id,@facecode=FacCode,@Businessid=BusinessId,@lasthearttime=LastHeartTime FROM dbo.YB_Device WHERE Ecode=@ecode

            --增加一条测量记录
            INSERT INTO dbo.YB_Result
            ([Weight],Height,Imp,TaskStatus,TakeTime,FansId,VrCode,EquId,Ecode,FamilyId,UserId,Createtime,[Type],PublicId,orderid,BusinessId)
            VALUES(@weight,@height,@imp,1,@createtime,ISNULL(@fansid,''),'',@equid,@ecode,@familyid,@userid,getdate(),@type,'','08D93BAC-E4BB-403E-8DE3-7E9AC647B5F4',@Businessid)

            SELECT @resultid=@@IDENTITY

            --增加一条测量记录扩展表
            INSERT INTO dbo.YB_ResultExt
            (ResultId,[Weight],Height,Imp,EquId,Ecode,FacEcode,SourceType,OrderId,PublicId,FansId,UserId,BusinessId,CreateTime,[Type])
            VALUES(@resultid,@weight,@height,@imp,@equid,@ecode,@facecode,@sourcetype,'08D93BAC-E4BB-403E-8DE3-7E9AC647B5F4','',ISNULL(@fansid,''),@userid,@Businessid,getdate(),@type)

            --增加计算结果记录
            INSERT INTO dbo.YB_Measure
            (ResultId,Sex,Age,Height,FamilyId,fat_r,muscle,water,bone,kcal,fat_w,visceral,protein,bodyage,bmi,cmi,
            sfr,muscleval,proteinval,lbm,body,fatlevel,createtime,[Month],[Weight],[Type])
            VALUES(@resultid,@sex,@age,@height,@familyid,@fat_r,@muscle,@water,@bone,@kcal,@fat_w,@visceral,@protein,@bodyage,@bmi,@cmi,
            @sfr,@muscleval,@proteinval,@lbm,@body,@fatlevel,getdate(),@month,@weight,@type)

            IF @lasthearttime =null OR DATEDIFF(DAY,GETDATE(),@lasthearttime) !=0
            BEGIN
                SET @isdevactive=1
            END

            --更新设备测量时间
            UPDATE dbo.YB_Device SET LastHeartTime=GETDATE() WHERE id=@equid
            --更新家庭成员的最新体重
            UPDATE dbo.YB_Family SET [Weight]=@weight,Height=@height,LastHeartTime=getdate() WHERE id=@familyid

            --更新家庭成员统计数据
            IF EXISTS(SELECT 1 FROM dbo.YB_FamilyData WHERE FamilyId=@familyid AND FirstResultTime IS NOT NULL)
            BEGIN
                UPDATE dbo.YB_FamilyData SET LastHeight=@height,LastWeight=@weight,LastResultTime=GETDATE(),
                TotalCount=TotalCount+1,TodayCount=TodayCount+1,LastTimeWeight=LastWeight-@weight,LastTimeHeight=LastHeight-@height WHERE familyid=@familyid
            END
            ELSE
            BEGIN
                UPDATE dbo.YB_FamilyData SET LastHeight=@height,LastWeight=@weight,LastResultTime=GETDATE(),TotalCount=TotalCount+1,TodayCount=TodayCount+1,
                FirstResultTime=GETDATE(),FirstWeight=@weight,FirstHeight=@height,LastTimeWeight=0,LastTimeHeight=0 WHERE familyid=@familyid
            END
            --更新合计统计
            IF NOT EXISTS(SELECT 1 FROM dbo.YB_Combined)
            BEGIN
                --活跃计数
                INSERT INTO dbo.YB_Combined
                    (id,TodayRegCnt,TotalRegCnt,TodayResultCnt,TotalResultCnt,TodayDevCnt,TotalDevCnt,TodayIncome,TotalIncome,BusinessCnt)
                    VALUES(1,0,0,1,1,@isdevactive,0,0,0,0)
            END
            ELSE
            BEGIN
                UPDATE dbo.YB_Combined SET TodayResultCnt=TodayResultCnt+1,TotalResultCnt=TotalResultCnt+1,
                TodayDevCnt=TodayDevCnt+@isdevactive WHERE id=1
            END

            --更新设备统计
            IF EXISTS(SELECT 1 FROM dbo.YB_EquRealData WHERE EquId=@equid AND BusinessId=@Businessid)
            BEGIN
                UPDATE dbo.YB_EquRealData SET TodayResultCnt=TodayResultCnt+1,TotalResultCnt=TotalResultCnt+1 WHERE EquId=@equid AND BusinessId=@Businessid
            END
            ELSE
            BEGIN
                INSERT INTO dbo.YB_EquRealData
                (EquId,BusinessId,TodayResultCnt,TotalResultCnt,TodayInCome,TotalInCome,CreateTime)
                VALUES(@equid,@Businessid,1,1,0,0,GETDATE())
            END

            --更新客户统计
            IF EXISTS(SELECT 1 FROM dbo.YB_BusinessRealData WHERE BusinessId=@Businessid)
            BEGIN
                UPDATE dbo.YB_BusinessRealData SET TodayResultCnt=TodayResultCnt+1,TotalResultCnt=TotalResultCnt+1,
                TodayDevCount=TodayDevCount+@isdevactive
                WHERE BusinessId=@Businessid
            END
            ELSE
            BEGIN
                INSERT INTO dbo.YB_BusinessRealData
                (BusinessId,TodayResultCnt,TotalResultCnt,TodayIncome,TotalIncome,Balance,TotalTxAmount,CreateTime,
                BusinessCount,TodayRealCnt,TotalRealCnt,DevCount,TodayDevCount)
                VALUES(@Businessid,1,1,0,0,0,0,GETDATE(),0,0,0,0,@isdevactive)
            END

            --如果是手动增加,则添加一条手动添加的记录
            IF @sourcetype=2
            BEGIN
                INSERT INTO dbo.YB_ResultAdd
                (ResultId,Height,[Weight],UserId,FamilyId,ResultTime,CreateTime)
                VALUES(@resultid,@height,@weight,@userid,@familyid,@createtime,GETDATE())
            END
            --COMMIT TRAN tran_jifei
        END

END


proc_insertscanresult

-- =============================================
-- Author:		liuzl
-- Create date: 2021-01-20
-- Description:	 扫码插入测量记录,暂时不用
-- Test:  exec   proc_insertscanresult 'oyXoU0mh4eCHhDWbbitccETst61w','789ce7004f58','oqmUFwt_NSdNGEBj8aLmW3jOhpXw','gh_afa49765ca4a','719573548',-1,25546363163804672
-- =============================================
CREATE PROCEDURE [dbo].[proc_insertscanresult]
    @sex INT=0,--性别,1-男,2-女,0-未知
    @age INT,--年龄
    @month INT=0,--相差的月份
    @height DECIMAL(18,2),--身高,厘米
    @weight DECIMAL(18,2),--体重,KG
    @imp  DECIMAL(18,2),--阻抗
    @ecode VARCHAR(50),--设备码
    @fansid VARCHAR(50)='',--用户唯一标识
    @familyid INT,--领取的家庭成员ID
    @userid INT, --用户ID
    @fat_r DECIMAL(18,2),--脂肪率
    @muscle DECIMAL(18,2),--肌肉率
    @water DECIMAL(18,2),--水份
    @bone DECIMAL(18,2),--骨重
    @kcal DECIMAL(18,2),--基础代谢
    @fat_w DECIMAL(18,2),--脂肪重量
    @visceral DECIMAL(18,2),--内脂
    @protein DECIMAL(18,2),--蛋白质
    @bodyage DECIMAL(18,2),--体龄
    @bmi DECIMAL(18,2),--bmi
    @cmi DECIMAL(18,2),--分数
    @sfr DECIMAL(18,2),--皮下脂肪
    @muscleval DECIMAL(18,2),--肌肉量
    @proteinval DECIMAL(18,2),--蛋白量
    @lbm DECIMAL(18,2),--去脂体重
    @body VARCHAR(50),--体型
    @fatlevel VARCHAR(50),--肥胖等级
    @sourcetype INT=1,-- 1-蓝牙传输,2-手动记录
    @createtime DATETIME=NULL,--测量时间,手动记录使用
    @resultid INT=0 --最新的记录id,如果传递此值,则进行更新操作
AS
BEGIN
DECLARE @equid INT,@facecode VARCHAR(50),@Businessid INT,@lasthearttime DATETIME,
@isdevactive INT=0 --设备活跃台数是否+1,0-否,1-是
        SET   XACT_ABORT   ON
        IF @resultid>0
        BEGIN
            --更新计算结果值
            UPDATE dbo.YB_Measure SET Height=@height,Sex=@sex,Age=@age,fat_r=@fat_r,muscle=@muscle,water=@water,
            bone=@bone,kcal=@kcal,fat_w=@fat_w,visceral=@visceral,protein=@protein,bodyage=@bodyage,bmi=@bmi,
            cmi=@cmi,sfr=@sfr,muscleval=@muscleval,proteinval=@proteinval,lbm=@lbm,body=@body,fatlevel=@fatlevel,
            [Month]=@month
            WHERE ResultId=@resultid
        END
        ELSE
        BEGIN
            IF @sourcetype=1
            BEGIN
                SET @createtime=GETDATE()
            END
            --BEGIN TRAN tran_jifei
            SELECT TOP 1 @equid=Id,@facecode=FacCode,@Businessid=BusinessId,@lasthearttime=LastHeartTime FROM dbo.YB_Device WHERE Ecode=@ecode

            --增加一条测量记录
            INSERT INTO dbo.YB_Result
            ([Weight],Height,Imp,TaskStatus,TakeTime,FansId,VrCode,EquId,Ecode,FamilyId,UserId,Createtime)
            VALUES(@weight,@height,@imp,1,GETDATE(),@fansid,'',@equid,@ecode,@familyid,@userid,@createtime)

            SELECT @resultid=@@IDENTITY

            --增加一条测量记录扩展表
            INSERT INTO dbo.YB_ResultExt
            (ResultId,[Weight],Height,Imp,EquId,Ecode,FacEcode,SourceType,OrderId,PublicId,FansId,UserId,BusinessId,CreateTime)
            VALUES(@resultid,@weight,@height,@imp,@equid,@ecode,@facecode,@sourcetype,'08D93BAC-E4BB-403E-8DE3-7E9AC647B5F4','',@fansid,@userid,@Businessid,@createtime)
            --增加计算结果记录
            INSERT INTO dbo.YB_Measure
            (ResultId,Sex,Age,Height,FamilyId,fat_r,muscle,water,bone,kcal,fat_w,visceral,protein,bodyage,bmi,cmi,
            sfr,muscleval,proteinval,lbm,body,fatlevel,createtime,[Month],[Weight])
            VALUES(@resultid,@sex,@age,@height,@familyid,@fat_r,@muscle,@water,@bone,@kcal,@fat_w,@visceral,@protein,@bodyage,@bmi,@cmi,
            @sfr,@muscleval,@proteinval,@lbm,@body,@fatlevel,@createtime,@month,@weight)

            IF @lasthearttime =null OR DATEDIFF(DAY,GETDATE(),@lasthearttime)=0
            BEGIN
                SET @isdevactive=1
            END

            --更新设备测量时间
            UPDATE dbo.YB_Device SET LastHeartTime=GETDATE() WHERE id=@equid
            --更新家庭成员的最新体重
            UPDATE dbo.YB_Family SET [Weight]=@weight,Height=@height,LastHeartTime=@createtime WHERE id=@familyid

            --更新合计统计
            IF EXISTS(SELECT 1 FROM dbo.YB_Combined)
            BEGIN
                --活跃计数
                IF @isdevactive=1
                BEGIN
                    INSERT INTO dbo.YB_Combined
                    (id,TodayRegCnt,TotalRegCnt,TodayResultCnt,TotalResultCnt,TodayDevCnt,TotalDevCnt,TodayIncome,TotalIncome)
                    VALUES(1,0,0,1,1,1,0,0,0)
                END
                ELSE
                BEGIN
                    INSERT INTO dbo.YB_Combined
                    (id,TodayRegCnt,TotalRegCnt,TodayResultCnt,TotalResultCnt,TodayDevCnt,TotalDevCnt,TodayIncome,TotalIncome)
                    VALUES(1,0,0,1,1,0,0,0,0)
                END
            END
            ELSE
            BEGIN
                --活跃计数
                IF @isdevactive=1
                BEGIN
                    UPDATE dbo.YB_Combined SET TodayResultCnt=TodayResultCnt+1,TodayDevCnt=TodayDevCnt+1 WHERE id=1
                END
                ELSE
                BEGIN
                    UPDATE dbo.YB_Combined SET TodayResultCnt=TodayResultCnt+1 WHERE id=1
                END
            END

            --更新设备统计
            IF EXISTS(SELECT 1 FROM dbo.YB_EquRealData WHERE id=@equid AND BusinessId=@Businessid)
            BEGIN
                UPDATE dbo.YB_EquRealData SET TodayResultCnt=TodayResultCnt+1,TotalResultCnt=TotalResultCnt+1 WHERE id=@equid AND BusinessId=@Businessid
            END
            ELSE
            BEGIN
                INSERT INTO dbo.YB_EquRealData
                (EquId,BusinessId,TodayResultCnt,TotalResultCnt,TodayInCome,TotalInCome,CreateTime)
                VALUES(@equid,@Businessid,1,1,0,0,GETDATE())
            END

            --更新客户统计
            IF EXISTS(SELECT 1 FROM dbo.YB_BusinessRealData WHERE BusinessId=@Businessid)
            BEGIN
                UPDATE dbo.YB_BusinessRealData SET TodayResultCnt=TodayResultCnt+1,TotalResultCnt=TotalResultCnt+1  WHERE BusinessId=@Businessid
            END
            ELSE
            BEGIN
                INSERT INTO dbo.YB_BusinessRealData
                (BusinessId,TodayResultCnt,TotalResultCnt,TodayIncome,TotalIncome,Balance,TotalTxAmount,CreateTime,DevCount)
                VALUES(@Businessid,1,1,0,0,0,0,GETDATE(),0)
            END

            --如果是手动增加,则添加一条手动添加的记录
            IF @sourcetype=2
            BEGIN
                INSERT INTO dbo.YB_ResultAdd
                (ResultId,Height,[Weight],UserId,FamilyId,ResultTime,CreateTime)
                VALUES(@resultid,@height,@weight,@userid,@familyid,@createtime,GETDATE())
            END
            --COMMIT TRAN tran_jifei
        END

END


proc_reportDayData

--=============================================
-- Author:		liuzl
-- Create date: 2021-03-15
-- Description:	统计当日数据
-- test: exec proc_reportDayData
-- =============================================
CREATE PROCEDURE [dbo].[proc_reportDayData]
AS
BEGIN
    SET NOCOUNT ON;
    DECLARE @dayregcnt INT,
    @dayresultcnt INT,
    @daydevcnt INT,
    @dayincome DECIMAL(18,2)=0,
    @yestodaytime DATETIME,
    @time DATETIME,
    @starttime DATETIME,
    @endtime DATETIME,
    @halfyeartime DATETIME,
    @halfyeartime1 DATETIME,
    @yeartime DATETIME,
    @yeartime1 DATETIME

    set @time=DATEADD(DAY,-1,GETDATE())
    SET @yestodaytime=@time
    SET @starttime=CONVERT(DATETIME,CONVERT(VARCHAR(10),@time,120))
    SET @endtime=CONVERT(DATETIME,CONVERT(VARCHAR(10),GETDATE(),120))
    SET @time=DATEADD(MONTH,-6,GETDATE())
    --SET @halfyeartime=CONVERT(DATETIME,CONVERT(VARCHAR(10),@time,120))
    --SET @halfyeartime1=DATEADD(d,1,@halfyeartime)
    SET @halfyeartime=DATEADD(MONTH,DATEDIFF(MONTH,0,@time),0)  --半年前的月份月初
    SET @halfyeartime1=DATEADD(m,1,@halfyeartime) --半年前的月份的月尾
    SET @time=DATEADD(YEAR,-1,GETDATE())
    --SET @yeartime=CONVERT(DATETIME,CONVERT(VARCHAR(10),@time,120))
    --SET @yeartime1=DATEADD(d,1,@yeartime)
    SET @yeartime=DATEADD(MONTH,DATEDIFF(MONTH,0,@time),0)  --一年前的月份月初
    SET @yeartime1=DATEADD(m,1,@yeartime) --一年前的月份的月尾

    SELECT BusinessId,EquId,COUNT(*)cnt INTO #temp1 FROM dbo.YB_nResult
    WHERE  CreateTime>=@starttime AND CreateTime<@endtime
    GROUP BY BusinessId,EquId

    --生成yb_dayreport数据
    SELECT @dayregcnt=COUNT(Id) FROM dbo.YB_RegUser WHERE CreateTime>=@starttime AND CreateTime<@endtime

    SELECT @dayresultcnt=SUM(cnt) FROM #temp1
    ;

    WITH aa AS(
        SELECT COUNT(EquId) cnt FROM #temp1
        GROUP BY EquId
    )

    SELECT @daydevcnt=COUNT(*) FROM aa

    DELETE FROM dbo.YB_DayReport WHERE RecordTime=@starttime

    INSERT INTO dbo.YB_DayReport
    (DayRegCnt,DayResultCnt,DayDevCnt,DayInCome,RecordTime)
    VALUES(@dayregcnt,ISNULL(@dayresultcnt,0),@daydevcnt,@dayincome,@yestodaytime)
    ;

    --生成yb_businessdayreport
    DELETE FROM dbo.YB_BusinessReportData WHERE RecordTime=@starttime
    SELECT *FROM #temp1
    INSERT INTO dbo.YB_BusinessReportData
    (
        DayResultCnt,
        DayDevCnt,
        DayInCome,
        BusinessId,
        RecordTime
    )
    SELECT SUM(cnt),COUNT(EquId),0,BusinessId,@starttime FROM #temp1
    GROUP BY BusinessId

    --生成YB_DeviceDayReportData
    DELETE FROM dbo.YB_DeviceDayReportData WHERE RecordTime=@starttime
    INSERT INTO dbo.YB_DeviceDayReportData
    (
        DayResultCnt,
        DayInCome,
        DevId,
        BusinessId,
        RecordTime
    )
    SELECT SUM(cnt),0,EquId,BusinessId,@starttime FROM #temp1
    GROUP BY EquId,BusinessId

    --生成yb_familydata
    ;
    --更新半年前身高
     WITH a AS (select?s.*??
        from?(?--取最高身高
????		select?a.Height,b.FamilyId,b.DevType,b.createtime,?row_number()?over?(partition?by?b.FamilyId?order?by?a.Height desc)?as?group_idx??
????		from?dbo.YB_nResult a
            LEFT JOIN dbo.YB_nUserResult b
            ON a.Id=b.Id
            WHERE b.createtime>=@halfyeartime AND b.createtime<@halfyeartime1 AND b.FamilyId !=0 AND b.[Status]=1
        )?s
        where?s.group_idx?=?1)

     UPDATE dbo.YB_FamilyRealData
     SET HalfYearHeight=ISNULL(a.Height,0),HalfYearHeightTime=a.CreateTime
    FROM a
    WHERE dbo.YB_FamilyRealData.FamilyId=a.FamilyId AND YB_FamilyRealData.DevType=a.DevType
    ;
    --更新一年前身高
     WITH a AS (select?s.*??
        from?(?--取最高身高
????		select?a.Height,b.FamilyId,b.DevType,b.createtime,?row_number()?over?(partition?by?b.FamilyId?order?by?a.Height desc)?as?group_idx??
????		from?dbo.YB_nResult a
            LEFT JOIN dbo.YB_nUserResult b
            ON a.Id=b.Id
            WHERE b.createtime>=@yeartime AND b.createtime<@yeartime1 AND b.FamilyId !=0 AND b.[Status]=1
        )?s
        where?s.group_idx?=?1)

     UPDATE dbo.YB_FamilyRealData
     SET YearHeight=ISNULL(a.Height,0),YearHeightTime=a.CreateTime
    FROM a
    WHERE dbo.YB_FamilyRealData.FamilyId=a.FamilyId AND YB_FamilyRealData.DevType=a.DevType
END


proc_reportmonthData

--=============================================
-- Author:		liuzl
-- Create date: 2021-03-15
-- Description:	每月数据统计
-- test: exec proc_reportmonthData
-- =============================================
CREATE PROCEDURE [dbo].[proc_reportmonthData]
AS
BEGIN
    SET NOCOUNT ON;
    DECLARE @time DATE,
    @startime DATE,
    @endtime DATE

    SET  @time=DATEADD(d,-1,GETDATE())
    SET @startime=DATEADD(MONTH,DATEDIFF(MONTH,0,@time),0) --上月月初
    SET @endtime=DATEADD(MONTH,DATEDIFF(MONTH,0,GETDATE()),0) --本月月初

    DELETE FROM dbo.YB_FamilyReportData WHERE CreateTime>=@startime AND CreateTime<@endtime

    INSERT INTO dbo.YB_FamilyReportData
    (FamilyId,Height,[Weight],CreateTime,DevType,LastWeightTime,Head)
    SELECT FamilyId,ISNULL(MonthHeight,0),ISNULL(LastWeight,0),@startime,DevType,LastResultTime,ISNULL(LastHead,0) FROM dbo.YB_FamilyRealData

    --INSERT INTO dbo.YB_FamilyReportData
    --(FamilyId,Height,[Weight],CreateTime,DevType)
    --select?s.FamilyId,s.Height,s.[Weight],@startime,1
    --	from?(?--取最高身高
?--???		select?*,?row_number()?over?(partition?by?FamilyId?order?by?Height desc)?as?group_idx??
?--???		from?dbo.YB_nUserResult WHERE createtime>=@startime AND createtime<	@endtime
    --	)?s
    --	where?s.group_idx?=?1

    --清理每月最高身高体重值
    UPDATE dbo.YB_FamilyRealData SET MonthHeight=0,MonthWeight=0,MonthHead=0
END


proc_saveresult

-- =============================================
-- Author:		liuzl
-- Create date: 2021-03-17
-- Description:	扫码增加记录
-- =============================================
CREATE proc [dbo].[proc_saveresult]
  @wxfansid UNIQUEIDENTIFIER,--粉丝记录id
  @type INT=1,--类型,1-单阻抗,2-八电极
  @vrcode varchar(50),--去重码
  @weight DECIMAL(18,2),--体重,kg
  @height DECIMAL(10,2),--身高,cm
  @imp DECIMAL(18,2),--阻抗,
  @fansid VARCHAR(50),--用户唯一标识
  @oldopenid VARCHAR(50),--针对网页授权号的openid
  @equid INT,--设备ID,
  @ecode VARCHAR(50),--设备机器码
  @facecode VARCHAR(50),--设备序列号
  @orderid UNIQUEIDENTIFIER,--订单id
  @businessid INT,--设备所属服务商
  @publicid VARCHAR(50),--公众号原始id
  @headimgurl VARCHAR(200),--用户头像
  @nickname NVARCHAR(100),--用户昵称
  @sex INT,--用户性别
  @city NVARCHAR(100),--城市
  @province NVARCHAR(100),--省份
  @country NVARCHAR(100),--国家
  @language VARCHAR(50),--语言
  @ordertype INT,--订单类型,1-公众号,2-链接,3-小程序
  @officetype INT,--公众号类型,1-认证的服务号,2-非认证号,3-个人号,4-小程序
  @lefthandimp DECIMAL(18,2),--左手阻抗
  @righthandimp DECIMAL(18,2),--右手阻抗
  @leftfootimp DECIMAL(18,2),--左脚阻抗
  @rightfootimp DECIMAL(18,2),--右脚阻抗
  @bodyimp DECIMAL(18,2),--全身阻抗
  @encode VARCHAR(50)='',--如果是非认证的号的健康码
  @resulttime DATETIME,--测量时间
  @messageid UNIQUEIDENTIFIER, --消息id,用以yb_wxmessage消息保存
  @scantype INT=1 --扫码类型,1-带测量参数的二维码,2-固定贴纸
  as
  begin
  DECLARE @resultid INT, --测量记录id
  @lasthearttime DATETIME,
    @isdevactive INT=0 --设备活跃台数是否+1,0-否,1-是
  SET   XACT_ABORT   ON
 --if not exists(select 1 from dbo.YB_Result where VrCode=@vrcode)
 --为公众号时
 IF @ordertype=1
    BEGIN
        --保存粉丝数据,-1-未知状态,0-取关,2-已关注
        IF EXISTS(SELECT 1 FROM dbo.YB_WXFans WHERE FansId=@fansid)
        BEGIN
            UPDATE dbo.YB_WXFans SET HeadImgUrl=@headimgurl,NickName=@nickname,sex=@sex,
            City=@city,Country=@country,Province=@province,[Language]=@language
            WHERE FansId=@fansid
            SELECT @wxfansid=Id FROM dbo.YB_WXFans WHERE FansId=@fansid
        END
        ELSE
        BEGIN
            INSERT INTO dbo.YB_WXFans
            (
                id,
                NickName,
                HeadImgUrl,
                Sex,
                City,
                Country,
                Province,
                [Language],
                FromType,
                OldOpenId,
                FansId,
                CreateTime
            )
            VALUES(@wxfansid,@nickname,@headimgurl,@sex,@city,@country,@province,@language,1,@oldopenid,@fansid,GETDATE())
        END
        --记录关注情况
        IF NOT EXISTS(SELECT 1 FROM dbo.YB_WXFansExt WHERE AppId=@publicid AND ResultId=@wxfansid)
        BEGIN
            INSERT into dbo.YB_WXFansExt
            (
                ResultId,
                AppId,
                OpenId,
                Subscribe,
                SubscribeTime
            )
            VALUES
            ( @wxfansid, @publicid, '',  -1, GETDATE())
        END
        --如果是带测量参数的二维码
        IF @scantype=1
        BEGIN
                --插入yb_result表
            INSERT INTO dbo.YB_Result
            (
                [Weight],
                Height,
                Imp,
                TaskStatus,
                TakeTime,
                FansId,
                VrCode,
                EquId,
                Ecode,
                FamilyId,
                UserId,
                Createtime,
                [Type],
                PublicId,
                OrderId,
                BusinessId
            )
            values(@weight,@height,@imp,0,NULL,@wxfansid,@vrcode,@equid,@ecode,0,0,GETDATE(),@type,@publicid,@orderid,@businessid)

            SELECT @resultid=@@IDENTITY
            --插入yb_resultext
            INSERT INTO dbo.YB_ResultExt
            (
                ResultId,
                [Weight],
                Height,
                Imp,
                EquId,
                Ecode,
                FacEcode,
                SourceType,
                OrderId,
                PublicId,
                FansId,
                UserId,
                BusinessId,
                CreateTime,
                [Type]
            )
            VALUES(@resultid,@weight,@height,@imp,@equid,@ecode,@facecode,3,@orderid,@publicid,@wxfansid,0,@businessid,GETDATE(),@type)

            --如果是非认证的公众号,则记录下健康码
            IF(@officetype = 2)
            BEGIN
                INSERT INTO dbo.YB_WXMessage
                (
                    Id,
                    EnCode,
                    ResultId,
                    PublicId,
                    CreateTime,
                    [Type]
                )
                VALUES(@messageid,@encode,@resultid,@publicid,GETDATE(),1)
            END

            --如果type=2,八电极
            IF @type=2
            BEGIN
                INSERT INTO dbo.YB_BodyResult
                (
                    ResultId,
                    LeftArmImp,
                    RightArmImp,
                    LeftLegImp,
                    RightLegImp,
                    BodyImp
                )
                VALUES
                (   @resultid,    -- ResultId - int
                    @lefthandimp, -- LeftArmImp - decimal(18, 2)
                    @righthandimp, -- RightArmImp - decimal(18, 2)
                    @leftfootimp, -- LeftLegImp - decimal(18, 2)
                    @rightfootimp, -- RightLegImp - decimal(18, 2)
                    @bodyimp  -- BodyImp - decimal(18, 2)
                    )
            END
            --插入或者更新yb_equrealdata
            IF NOT EXISTS(SELECT 1 FROM dbo.YB_EquRealData WHERE EquId=@equid AND BusinessId=@businessid)
            BEGIN
                INSERT INTO dbo.YB_EquRealData
                (
                    EquId,
                    BusinessId,
                    TodayResultCnt,
                    TotalResultCnt,
                    TodayInCome,
                    TotalInCome,
                    CreateTime
                )
                VALUES(@equid,@businessid,1,1,0,0,GETDATE())
            END
            ELSE
            BEGIN
                UPDATE dbo.YB_EquRealData SET TodayResultCnt=TodayResultCnt+1,TotalResultCnt=TotalResultCnt+1 WHERE EquId=@equid AND BusinessId=@businessid
            END

        --获取设备信息
        SELECT TOP 1 @lasthearttime=LastHeartTime FROM dbo.YB_Device WHERE Ecode=@ecode
        IF @lasthearttime =null OR DATEDIFF(DAY,GETDATE(),@lasthearttime) !=0
            BEGIN
                SET @isdevactive=1
            END
        --更新设备最近测量时间
        UPDATE dbo.YB_Device SET LastHeartTime=GETDATE() WHERE id=@equid
        --更新订单计数
        UPDATE dbo.YB_Order SET showcount=showcount+1,DayCount=DayCount+1 WHERE id=@orderid

        --更新合计统计
        IF NOT EXISTS(SELECT 1 FROM dbo.YB_Combined)
            BEGIN
                INSERT INTO dbo.YB_Combined
                    (id,TodayRegCnt,TotalRegCnt,TodayResultCnt,TotalResultCnt,TodayDevCnt,TotalDevCnt,TodayIncome,TotalIncome,BusinessCnt)
                    VALUES(1,0,0,1,1,@isdevactive,0,0,0,0)
            END
            ELSE
            BEGIN
                UPDATE dbo.YB_Combined SET TodayResultCnt=TodayResultCnt+1,TotalResultCnt=TotalResultCnt+1, TodayDevCnt=TodayDevCnt+@isdevactive WHERE id=1
            END
        --更新客户统计
            IF EXISTS(SELECT 1 FROM dbo.YB_BusinessRealData WHERE BusinessId=@Businessid)
            BEGIN
                UPDATE dbo.YB_BusinessRealData SET TodayResultCnt=TodayResultCnt+1,TotalResultCnt=TotalResultCnt+1,
                TodayDevCount=TodayDevCount+@isdevactive  WHERE BusinessId=@Businessid
            END
            ELSE
            BEGIN
                INSERT INTO dbo.YB_BusinessRealData
                (BusinessId,TodayResultCnt,TotalResultCnt,TodayIncome,TotalIncome,Balance,TotalTxAmount,CreateTime,BusinessCount,TodayRealCnt,TotalRealCnt,TodayDevCount)
                VALUES(@Businessid,1,1,0,0,0,0,GETDATE(),0,0,0,@isdevactive)
            END

        END
        ELSE
        BEGIN
            --增加扫码记录
            INSERT INTO dbo.YB_ScanResult
            (
                Id,
                Type,
                Subscribe,
                TakeTime,
                FansId,
                PublicId,
                OrderId,
                BusinessId,
                EquId,
                CreateTime
            )
            VALUES(@messageid,@type,0,NULL,@wxfansid,@publicid,@orderid,@businessid,@equid,GETDATE())

            --如果是非认证的公众号,则记录下健康码
            IF(@officetype = 2)
            BEGIN
                INSERT INTO dbo.YB_WXMessage
                (
                    Id,
                    EnCode,
                    ResultId,
                    PublicId,
                    CreateTime,
                    [Type]
                )
                VALUES(@messageid,@encode,@messageid,@publicid,GETDATE(),2)
            END

            --更新订单计数
            UPDATE dbo.YB_Order SET showcount=showcount+1,DayCount=DayCount+1 WHERE id=@orderid
        END
  end
  ELSE
  BEGIN
    --更新订单
    UPDATE dbo.YB_Order SET ShowCount=ShowCount+1,DayCount=DayCount+1 WHERE id=@orderid
  END
end


proc_updateresult

-- =============================================
-- Author:		liuzl
-- Create date: 2021-07-05
-- Description: 更新扫码时的关注状态
-- test: exec proc_updateresult '','gh_740e94501e5b',13,'08d9476d-a200-4517-8754-bf614560537e','o2No265s2YTuDN4CQwfCcdflk4L0',2,1
-- =============================================
CREATE  PROCEDURE [dbo].[proc_updateresult]
@encode VARCHAR(50),--健康码
@appid VARCHAR(50),--微信公众号原始id
@equid INT,--设备id
@fansid VARCHAR(50), --用户fansid
@openid VARCHAR(50),--用户openid
@type INT, --1-认证的服务号关注事件,2-认证的服务号扫码事件,3-非认证关注事件,4-回复关键字,5-第一次打开落地页,6-非认证扫码事件
@scantype INT=1 --1-带测量参数的二维码,2-固定二维码
AS
BEGIN
DECLARE @resultid INT, --测量记录id
@messageid UNIQUEIDENTIFIER ,--扫码记录id
@orderid UNIQUEIDENTIFIER,--订单id
@wxfansid UNIQUEIDENTIFIER,--粉丝id
@takestatus INT,--原先的计费状态,0-未领取,1-已领取,-1-未知状态,2-重复领取
@is_subscribe INT=-1,--要更新的计费状态
@devtype INT,--1-单电阻,2-八电极
@businessid INT --商户id

--如果是带测量参数的二维码
IF @scantype=1
BEGIN
        --如果是认证的服务号
    IF @type=1 OR @type = 2
    BEGIN
        SELECT TOP 1 @takestatus=TaskStatus,@wxfansid=fansid, @resultid=id,@businessid=BusinessId,@orderid=OrderId,@equid=EquId,@devtype=[Type]
        FROM dbo.YB_Result WHERE FansId=@fansid AND PublicId=@appid ORDER BY Createtime desc
    END
    --如果是回复关键字
    ELSE IF @type=4
    BEGIN
        SELECT TOP 1 @resultid=ResultId FROM dbo.YB_WXMessage WHERE EnCode=@encode AND PublicId=@appid AND [Type]=1 ORDER BY CreateTime DESC

        SELECT TOP 1 @takestatus=TaskStatus,@wxfansid=fansid, @businessid=BusinessId,@orderid=OrderId,@equid=EquId,@devtype=[Type] FROM dbo.YB_Result WHERE id=@resultid
    END
    ELSE
    BEGIN
        SELECT TOP 1 @takestatus=TaskStatus,@wxfansid=fansid, @resultid=id,@businessid=BusinessId,@orderid=OrderId,@equid=EquId,@devtype=[Type] FROM dbo.YB_Result WHERE FansId=@fansid AND PublicId=@appid ORDER BY Createtime desc
    END
    IF @resultid IS NOT NULL
    BEGIN
        --检查结果表是否对于此粉丝计费过
            SET NOCOUNT ON;
            BEGIN TRAN tran_savesubscribe
            --如果是认证服务号的关注事件
            IF @type=1
            BEGIN
                SET @is_subscribe=1
                --如果今日已关注过,则为重复关注
                IF EXISTS(SELECT 1 FROM dbo.YB_Result WHERE FansId=@wxfansid AND PublicId=@appid AND TaskStatus=1 AND DATEDIFF(day,Createtime,GETDATE()) =0)
                BEGIN
                    SET @is_subscribe=2
                END
            END
            --认证的服务号扫码事件
            ELSE IF @type=2
            BEGIN
                SET @is_subscribe=2

            END
            --打开落地页
            ELSE IF @type=5 OR @type=4
            BEGIN
                IF
                EXISTS(SELECT 1 FROM dbo.YB_Result WHERE FansId=@wxfansid AND PublicId=@appid AND TaskStatus !=-1)
                OR
                EXISTS(SELECT 1 FROM dbo.YB_ResultExt a LEFT JOIN dbo.YB_Measure b ON a.ResultId=b.ResultId WHERE a.FansId=@wxfansid AND a.PublicId=@appid AND b.TakeStatus=1)
                BEGIN
                    SET @is_subscribe=2
                END
            END
            --更新yb_result表
            UPDATE dbo.YB_Result SET TaskStatus=@is_subscribe,TakeTime=GETDATE() WHERE id=@resultid AND TaskStatus !=1 AND TaskStatus !=2
            --更新wxfansext
            UPDATE dbo.YB_WXFansExt SET Subscribe=1,SubscribeTime=GETDATE(),OpenId=@openid WHERE  ResultId=@wxfansid AND Subscribe !=1

            --添加yb_measure信息
            IF NOT EXISTS(SELECT 1 FROM dbo.YB_Measure WHERE ResultId=@resultid)
            BEGIN
                INSERT INTO dbo.YB_Measure
                (
                    ResultId,
                    Sex,
                    Age,
                    Month,
                    Height,
                    Weight,
                    FamilyId,
                    fat_r,
                    muscle,
                    water,
                    bone,
                    kcal,
                    fat_w,
                    visceral,
                    protein,
                    bodyage,
                    bmi,
                    cmi,
                    sfr,
                    muscleval,
                    proteinval,
                    lbm,
                    body,
                    fatlevel,
                    createtime,
                    Type,
                    TakeStatus
                )
                SELECT TOP 1 id,0,0,0,Height,Weight,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,'','',GETDATE(),@type,@is_subscribe FROM dbo.YB_Result WHERE id=@resultid

                IF @devtype=2
                BEGIN
                    INSERT INTO dbo.YB_BodyMeasure
                    (
                        ResultId,
                        BodyMuscle,
                        LeftFootMuscle,
                        RightFootMuscle,
                        LeftHandMuscle,
                        RightHandMuscle,
                        BodyFat,
                        LeftFootFat,
                        RightFootFat,
                        LeftHandFat,
                        RightHandFat,
                        BodyMuscleVal,
                        LeftFootMuscleVal,
                        RightFootMuscleVal,
                        LeftHandMuscleVal,
                        RightHandMuscleVal,
                        BodyFatVal,
                        LeftFootFatVal,
                        RightFootFatVal,
                        LeftHandFatVal,
                        RightHandFatVal,
                        SfrVal,
                        IdealWeight,
                        SkeletalMuscle,
                        LevelJson
                    )
                    VALUES(@resultid,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,'')
                END
            END
            --修改相关信息
            IF @is_subscribe=1
            BEGIN
                --更新订单
                UPDATE dbo.YB_Order SET RealCount=RealCount+1,DayRealCount=DayRealCount+1 WHERE id=@orderid

                --更新设备
                UPDATE dbo.YB_EquRealData SET TodayRealCnt=TodayRealCnt+1,TotalRealCnt=TotalRealCnt+1 WHERE id=@equid
                --更新商户
                UPDATE dbo.YB_BusinessRealData SET TodayRealCnt=TodayRealCnt+1,TotalRealCnt=TotalRealCnt+1 WHERE BusinessId=@businessid
            END

            --删除yb_wxmessage
            DELETE FROM dbo.YB_WXMessage WHERE ResultId=@resultid

            COMMIT TRAN tran_savesubscribe
    END
END
ELSE
--固定贴纸二维码
BEGIN
        --如果是认证的服务号
    IF @type=1 OR @type = 2
    BEGIN
        SELECT TOP 1 @wxfansid=fansid, @messageid=id,@businessid=BusinessId,@orderid=OrderId,@equid=EquId
        FROM dbo.YB_ScanResult WHERE FansId=@fansid AND PublicId=@appid
        ORDER BY Createtime desc
    END
    --如果是回复关键字
    ELSE IF @type=4
    BEGIN
        SELECT TOP 1 @messageid=ResultId FROM dbo.YB_WXMessage WHERE EnCode=@encode AND PublicId=@appid AND [Type]=2 ORDER BY CreateTime DESC

        SELECT TOP 1 @wxfansid=fansid, @businessid=BusinessId,@orderid=OrderId,@equid=EquId FROM dbo.YB_ScanResult WHERE id=@messageid
    END
    ELSE
    BEGIN
        SELECT TOP 1 @wxfansid=fansid, @messageid=id,@businessid=BusinessId,@orderid=OrderId,@equid=EquId FROM dbo.YB_ScanResult
        WHERE FansId=@fansid AND PublicId=@appid
        ORDER BY Createtime desc
    END

    IF @messageid IS NOT NULL
    BEGIN
        --检查结果表是否对于此粉丝计费过
            SET NOCOUNT ON;
            BEGIN TRAN tran_savesubscribe
            --如果是认证服务号的关注事件
            IF @type=1
            BEGIN
                SET @is_subscribe=1
                --如果今日已关注过,则为重复关注
                IF EXISTS(SELECT 1 FROM dbo.YB_ScanResult WHERE FansId=@wxfansid AND PublicId=@appid AND Subscribe=1 AND DATEDIFF(day,Createtime,GETDATE()) =0)
                BEGIN
                    SET @is_subscribe=2
                END
            END
            --认证的服务号扫码事件
            ELSE IF @type=2
            BEGIN
                SET @is_subscribe=2

            END
            --打开落地页
            ELSE IF @type=5 OR @type=4
            BEGIN
                IF EXISTS(SELECT 1 FROM dbo.YB_ScanResult a WHERE a.FansId=@wxfansid AND a.PublicId=@appid AND a.Subscribe=1)
                BEGIN
                    SET @is_subscribe=2
                END
            END
            --更新yb_result表
            UPDATE dbo.YB_ScanResult SET Subscribe=@is_subscribe,TakeTime=GETDATE() WHERE id=@messageid AND Subscribe !=1 AND Subscribe !=2

            --更新wxfansext
            UPDATE dbo.YB_WXFansExt SET Subscribe=1,SubscribeTime=GETDATE(),OpenId=@openid WHERE  ResultId=@wxfansid AND Subscribe !=1

            --修改相关信息
            IF @is_subscribe=1
            BEGIN
                --更新订单
                UPDATE dbo.YB_Order SET RealCount=RealCount+1,DayRealCount=DayRealCount+1 WHERE id=@orderid

                --更新设备
                UPDATE dbo.YB_EquRealData SET TodayRealCnt=TodayRealCnt+1,TotalRealCnt=TotalRealCnt+1 WHERE id=@equid
                --更新商户
                UPDATE dbo.YB_BusinessRealData SET TodayRealCnt=TodayRealCnt+1,TotalRealCnt=TotalRealCnt+1 WHERE BusinessId=@businessid
            END

            --删除yb_wxmessage
            DELETE FROM dbo.YB_WXMessage WHERE ResultId=@messageid

            COMMIT TRAN tran_savesubscribe
    END
END
    SELECT TOP 1 * FROM dbo.YB_Device WHERE id=@equid
END


report_childheightandweight

CREATE PROCEDURE [dbo].[report_childheightandweight] AS

DECLARE @endtime DATETIME,@starttime DATETIME,@currenttime DATETIME

SET @currenttime=DATEADD(d,0,convert(char(10),GetDate(),120))
SET @endtime=DATEADD(d,-1,convert(char(10),GetDate(),120))
SET @starttime=DATEADD(day,-day(@endtime),convert(char(10),GetDate(),120))

SELECT TOP 1 FamilyId FROM dbo.YB_Measure WHERE createtime<@currenttime AND createtime>=@starttime
GROUP BY FamilyId